PyLint not showing in Problems

Anonymous
2011-08-15
2013-03-15
  • Anonymous - 2011-08-15

    I'm using Eclipse Helios build id 20110218-0911 and PyDev 2.2.1.2011071313 on Mac OS X 10.7. First, I should mention that everything was working fine before I upgraded to OS X Lion. After doing that, things were very broken, but I was able to fix most problems by reconfiguring PyDev (updating the library paths) and reinstalling PyLint using easy_install. Everything seems to be working now except for one thing. When I save a file or do a project clean, PyLint runs successfully and shows the output in Console, but none of the issues it finds are shown in the Problems tab. Any idea how to fix this?

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2011-08-15

    Not sure what may be happening… Do you have some error in your error log? Are your files under a source folder? Maybe you have some filter that's hiding those issues?

    Cheers,

    Fabio

     
  • Anonymous - 2011-08-15

    At the bottom of the PyLint output, there is "PyLint: The stderr of the command line is: No config file found, using default configuration", but I don't see anything else.

     
  • Anonymous - 2011-08-16

    Ok, I do have errors in my error log. I'm not too familiar with Eclipse so I didn't know exactly what you were referring to. They all look like this:

    For input string: "9,0"
    Exception stack trace:
    java.lang.NumberFormatException: For input string: "9,0"
        at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
        at java.lang.Integer.parseInt(Integer.java:481)
        at java.lang.Integer.parseInt(Integer.java:514)
        at org.python.pydev.builder.pylint.PyLintVisitor$PyLintThread.passPyLint(PyLintVisitor.java:301)
        at org.python.pydev.builder.pylint.PyLintVisitor$PyLintThread.run(PyLintVisitor.java:107)
    Session Data:
    eclipse.buildId=M20100211-1343
    java.version=1.6.0_22
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
    Command-line arguments:  -os linux -ws gtk -arch x86_64
    

    There's one for every line pylint finds an issue on, it seems. Also, though I said in my original post that I was on Mac OS X, I migrated my workspace to my Linux machine, hence the session data, but am getting the same problems.

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2011-08-16

    Can you create a bug report and add the output that pylint is giving you when you run it?

    Also, please add information on the pylint version you're using.

    Cheers,

    Fabio

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2011-08-18

    Just fixed. Please grab the nightly build in a couple of hours to see if it works for you.

    Cheers,

    Fabio

     
  • Piotr Dobrogost

    Piotr Dobrogost - 2011-08-18

    Verified using PyDev 2.2.1.2011081814 and PyLint 0.24.0 - bug is fixed.

     
  • Anonymous - 2011-08-29

    Yes, bug is fixed! Thank you.