Pydev 1.5.0 (Pydev Extensions open sourced)

2009-09-04
2013-03-15
  • Fabio Zadrozny

    Fabio Zadrozny - 2009-09-04

    Hi All,

    Today, Aptana is proud to announce that Pydev and Pydev Extensions
    have become a single plugin, with all the available contents open
    source (and freely available for anyone) in the 1.5.0 release (it's
    the same as 1.4.8 but with all the code open source).

    With that, Aptana believes in providing a better service and growth
    path for Pydev (which will still be actively maintained by Aptana),
    enabling anyone to provide contributions to the previously closed
    source product, while providing its Cloud customers a better service.

    Note for those already using Pydev or Pydev Extensions:

    The update site has been changed (see:
    http://www.pydev.org/download.html for more details) and if you had
    a previous install of Pydev Extensions, you need to uninstall it
    before installing the new version of Pydev.

    Note for developers:

    Pydev is now available under git (at github), and its previously used
    subversion will be disabled. Instructions on getting the source code
    from the new location is available at:
    http://www.pydev.org/developers.html

    Best Regards,

    --
    Fabio Zadrozny

    Aptana
    http://aptana.com

    Pydev - Python Development Environment for Eclipse
    http://pydev.org
    http://pydev.blogspot.com

     
    • Nicola

      Nicola - 2009-09-05

      Hi Fabio,

      I update from 1.4.8 (open source) to 1.5 today and after that pylint give strange errors here is an example:

      from PyQt4.QtCore import *
      from PyQt4.QtGui import *

      q=QWidget()  # here pylint give undefined variable: QWidget

      I only update pydev not pylint and with pydev 1.4.8 I don'have this pylint warning,

      any hints?

      Nicola

       
      • Fabio Zadrozny

        Fabio Zadrozny - 2009-09-07

        This may be due to the pydev extensions code-analysis. If you request a code-completion there, do you get QWidget as a suggestion? This may mean that you don't have your pythonpath properly set or have some active firewall, as it's not being able to get the builtins from PyQt4 properly.

        Cheers,

        Fabio

         
    • Christoph Zwerschke

      Great news - thanks a lot!

      Btw, is the Mylyn Integration now included in Pydev as well or do I still need to install something?

       
      • Fabio Zadrozny

        Fabio Zadrozny - 2009-09-07

        The mylyn plugin is still separate -- as it was before --because of the mylyn dependency.

        Cheers,

        Fabio

         
        • Christoph Zwerschke

          That makes sense. But it would be nice to have it on the new update site as well.

          It's only needed for the integration with the Pydev package explorer, right?

           
          • Fabio Zadrozny

            Fabio Zadrozny - 2009-09-07

            Oops, it was actually there already, but the p2 information for eclipse was not correct (so, I just regenerated it and it should be available now).

            And yes, it's only needed for the pydev package explorer integration.

            Cheers,

            Fabio

             
            • Christoph Zwerschke

              Thanks - I was able to install it from the new site now.

               
    • Nicola

      Nicola - 2009-09-08

      Thanks Fabio,

      disabling code analysis make pydev works as before,

      Nicola

       
      • Fabio Zadrozny

        Fabio Zadrozny - 2009-09-08

        Ok.

        Still, note that it should work properly, and this is probably a misconfiguration in your environment (you probably won't have code-completion for it either -- which you should have).

        Cheers,

        Fabio

         
    • Nicola

      Nicola - 2009-09-08

      Fabio,

      code completion works fine so pythonpath seems ok. I'm using eclipse galileo on linux x86_64 with jdk 6u16. What environment configuration can be wrong? How can I send additional info?

      thanks
      Nicola

       
    • Jason Jackson

      Jason Jackson - 2009-09-09

      I have also experienced the same thing that Nicola did. PyQt4 code completion worked fine in pydev 1.4.8. After updating to 1.5.0 it stopped working. Disabling the code analysis option brought code completion back.

       
  • drmaples

    drmaples - 2009-09-23

    could you please provide more detailed information about building pydev from the new git repository (and possibly include some screenshots).  the info listed here http://pydev.org/developers.html seems a bit sparse.  also, some more information about creating patches would be nice.