Mylar requirement in plugin installation

  • David Harris

    David Harris - 2007-07-20

    From the message on 7/19/07, I see that some are able to run PyDev and Eclipse 3.3. However, when I attempt to use Eclipse 'Software Updates' to load PyDev, I see this error message at the top of the Updates dialog:

    Requested operation cannot be performed because it would invalidate the current configuration. See details for more information.
      Pydev Mylar Integration (0.2.0) requires plug-in "org.eclipse.mylar (2.0.0.v20070403-1300)", or later version.

    In the module tree, 'Pydev Mylar Integration 0.2.0' is shown under Pydev Optional Extensions.

    Until the mylyn replacement is made, it would be much less confusing if the 'optional' mylar element was removed.

    Just a suggestion,
    Dave Harris

    • Kenneth Evans

      Kenneth Evans - 2007-07-31

      I have the same problem.  What comes with Eclipse 3.3 (via Europa) is Mylyn, the new name for Mylar.  Apparently the PyDev feature requires org.eclipse.mylar, whereas it should probably require Mylyn to be used with Eclipse 3.3.

      I am assuming what is on the update site is PyDev 1.3.8 since the date is after that was released.

      I note that says it is Mylyn integration for 1.38, but says Mylar.

      A workaround is to not check "Pydev optional extensions" in the Update dialog.

      Note: Subclipse has the same problem with a similar workaround.

      Just what does Mylyn add anyway?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks