#847 interactive console while debugging does not work

1.4.2
closed-invalid
debugger (210)
5
2009-02-10
2009-02-04
No

Following this page http://fabioz.com/pydev/manual_adv_debug_console.html I tried entering some expressions and statements while debugger was stopped at a breakpoint. But nothing happens. What I type appears, in cyan or aquamarine or some such color, like in the screenshot in the abovementioned page, but no response appears — see screenshot.

I am attempting this in the correct view, right? State of debugger is suspended, at a breakpoint. I am in version 1.4.2, with PyDev Extensions installed and licensed. Am I missing some setting to activate this? If not, how would I go about troubleshooting it? Nothing relevant appears in .metadata/.log

Discussion

  • Fabio Zadrozny
    Fabio Zadrozny
    2009-02-10

    One thing you didn't do is that for it to be evaluated, currently you need to add an additional new line after the line you want to evaluate, which doesn't seem to be what you're doing in your case (it's explained in http://fabioz.com/pydev/manual_adv_debug_console.html at the end of the page)

    If that's not it, please specify the eclipse version you're using and try to see if it works in a really simple example (e.g.: just create a very simple standalone script to check it and attach it to this bug)

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2009-02-10

    • status: open --> pending
     
  • Yep, I missed the part about pressing enter twice, sorry!

     
    • status: pending --> open
     
  • Fabio Zadrozny
    Fabio Zadrozny
    2009-02-10

    No problems.

     
  • Fabio Zadrozny
    Fabio Zadrozny
    2009-02-10

    • status: open --> closed-invalid