#787 Font not maintained between eclipse sessions

1.3.19
closed
Editor (491)
5
2008-10-02
2008-09-15
No

When eclipse is opened and there are no python (.py) files opened for editing, the first .py file opened will cause the python editor to use a font other than that defined in the default text preferences. If you change the default text preference or apply the current one, the python editor will update with the correct font. If you close eclipse and reopen it where the last .py file is opened by default, the font is still correct. If you close the .py file, close and open eclipse, and open the .py file again, the font will again be a font other than that defined in the default text prefs.

Discussion

  • Fabio Zadrozny

    Fabio Zadrozny - 2008-09-15

    What's your eclipse version/java vm/OS ?

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-09-15
    • status: open --> pending
     
  • Charles Rolls

    Charles Rolls - 2008-09-15

    MyEclipse version = 6.0.1-GA-200710
    java vm = MyEclipse Java VM (5.0.110.3)
    OS = WinXP

     
  • Charles Rolls

    Charles Rolls - 2008-09-15
    • status: pending --> open
     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-09-17
    • status: open --> pending
     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-09-17

    The text prefs you're editing is in window > preferences > general > appearance > colors and fonts > basic > text font ?
    (asking because I'm trying to reproduce it but it's working for me... also, do you know which version of eclipse is that one from myeclipse? e.g.: eclipse 3.3 / eclipse 3.4?

     
  • Charles Rolls

    Charles Rolls - 2008-09-17
    • status: pending --> open
     
  • Charles Rolls

    Charles Rolls - 2008-09-17

    Yes, that is where I change the font. Mine is set to Courier New, Regular, 10. MyEclipse eclipse ver is 3.3.0.v20070530. Remember, you must close all pyhton editors before closing eclipse. Then when you open eclipse and open your first python editor, the font is not correct.

     
  • Charles Rolls

    Charles Rolls - 2008-09-17

    I just did a test with plain eclipse 3.3 and did NOT have a problem with the fonts. This leads me to believe the issue is somewhere in MyEclipse. Do you think it may still have something to do with the plugin or maybe MyEclipse modified some eclipse code that raises the issue? I apologize that I did not try this earlier in order to narrow the problem scope.

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-09-17

    I don't really know... maybe a newer MyEclipse version has that already fixed?

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-09-17
    • status: open --> pending
     
  • SourceForge Robot

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending --> closed