#736 Conditional break point not working with new lines

1.3.18
closed-fixed
debugger (210)
5
2008-08-06
2008-06-26
No

Hi,

I am setting breakpoints successfully in PyDev.

When I enable conditions, I get the following error during the debugging session

Traceback (most recent call last):
File "T:\global\software-ext\win32\eclipse\v3_4\plugins\org.python.pydev.debug_1.3.18\pysrc\pydevd_comm.py", line 186, in OnRun
GlobalDebuggerHolder.globalDbg.processNetCommand(int(args[0]), int(args[1]), args[2])
ValueError: invalid literal for int() with base 10: ''

Regards

Discussion

  • Fabio Zadrozny

    Fabio Zadrozny - 2008-06-29
    • status: open --> pending
     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-06-29

    Logged In: YES
    user_id=617340
    Originator: NO

    I've tried that with a short example and it worked... Can you give more info on how you're reproducing it? (if possible a sample script and the condition you're using)

     
  • Nicholas Yue

    Nicholas Yue - 2008-06-30
    • status: pending --> open
     
  • Nicholas Yue

    Nicholas Yue - 2008-06-30

    Logged In: YES
    user_id=315253
    Originator: YES

    # Put breakpoint on the line "y = x"
    # Condition is i == 50
    def myFunction():
    for i in range(100):
    x = i
    y = x
    print y

    if __name__ == "__main__":
    myFunction()

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-08-01

    Logged In: YES
    user_id=617340
    Originator: NO

    Ok, I've just checked it, and it appears that all goes well on eclipse 3.3 (just now I saw that you're on eclipse 3.4)... I'll take a look at it, but just to note, the currently official eclipse version supported is eclipse 3.3 (mainly because of unresolved bugs in the debugger).

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-08-01
    • summary: Conditional break point not working --> Conditional break point not working in eclipse 3.4
     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-08-06
    • summary: Conditional break point not working in eclipse 3.4 --> Conditional break point not working with new lines
     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-08-06

    Logged In: YES
    user_id=617340
    Originator: NO

    Ok, I've been able to reproduce it... the problem happens when the properties edited have a '\n' (so, if you edit the properties removing all new lines, it should work)

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-08-06

    Logged In: YES
    user_id=617340
    Originator: NO

    Fixed for 1.3.20

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2008-08-06
    • status: open --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks