Support for older Python and CLIPS to be dropped

Since Python 2.3 and CLIPS 6.23 have been around for years now, I finally decided to drop support for versions of the two interpreters below the above mentioned ones. This is part of a major reorganization of the low-level module (the one coded in C) as well as the result of some considerations, including the availability of patches that address particular issues only for the most recent versions of CLIPS. CLIPS version 6.23 also introduces some new features that PyCLIPS enables.

The Python API, moreover, has undergone some small changes in version 2.3 that make it incompatible with version 2.2 and below. As Python 2.3 has been released nearly 3 years ago, and most platforms support it already (unfortunately it looks like there are still some embedded installations which stick to 2.2), I decided that it was time to remove legacy code from the module and drop support for older Python versions.

For those who still need a version of PyCLIPS that is compatible with Python 2.2 and CLIPS 6.22, I suggest to checkout SVN revision 276, which is the most improved one that still supports those platforms.

Posted by Francesco Garosi 2006-05-29

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks