Tree [1a5629] master /
 History

HTTPS access


File Date Author Commit
 Pyblio 2010-10-28 Zoltan Kota Zoltan Kota [1a5629] clean directories
 demo 2007-08-15 Frederic Gobry Frederic Gobry [5f18c0] add support for Citeseer, some renaming and doc...
 doc 2010-10-28 Zoltan Kota Zoltan Kota [1a5629] clean directories
 tests 2010-10-28 Zoltan Kota Zoltan Kota [1a5629] clean directories
 ChangeLog-1.0 2003-11-05 Frederic Gobry Frederic Gobry [d6a416] write schema xml
 ChangeLog-1.2 2003-11-05 Frederic Gobry Frederic Gobry [d6a416] write schema xml
 ChangeLog-1.3 2006-01-19 Frederic Gobry Frederic Gobry [3796b3] completed packaging process
 MANIFEST.in 2007-08-30 Frederic Gobry Frederic Gobry [4fc7c0] merged additional elementtree & misc fixes from...
 NEWS 2007-02-19 Frederic Gobry Frederic Gobry [45f0b6] refactored the result sets storage
 README 2006-09-05 Frederic Gobry Frederic Gobry [fb7a98] multiple fixes to the PubMed parser and the Bib...
 STORIES 2006-01-19 Frederic Gobry Frederic Gobry [3796b3] completed packaging process
 TODO 2006-04-11 Frederic Gobry Frederic Gobry [161ac3] improvements in the speed of the bsddb store
 ez_setup.py 2007-05-16 Frederic Gobry Frederic Gobry [8d4dac] updated ez_setup.py to 0.6c5
 setup.py 2007-09-08 Frederic Gobry Frederic Gobry [7e769b] provide the core version as a module variable

Read Me

-*- text -*-

This is the core API of the pybliographer framework. It provides
classes for managing bibliographic databases (storage, query,
conversion, formatting,...)


= Getting started =

Once the package is installed (see below), you can use the following
entry points to learn how it works:

  - the examples/ directory contains a few simple scripts with
    comments

  - the reference manual is available in HTML format in the doc/
    directory.


= Installation =

This package uses easy_install, and should fetch some dependencies
itself (except for the ones listed below).


== Requirements ==

 * python >= 2.3

 * ElementTree and cElementTree (<http://effbot.org/zone/element-index.htm>)

 * numpy >= 1.0b1 (<http://numpy.scipy.org/>)

== Optional dependencies ==

 * In order to use the bsddb store, you need a recent pybsddb version
   (>= 4.3.3) (<http://pybsddb.sourceforge.net/>)
  
    WARNING: the latest python version at that time (2.4.2) has not yet
    the requested version of pybsddb.

 * In order to run external queries (to the Web of Science for instance),
   you need to install Twisted (<http://twistedmatrix.com/>).
 

== Global installation ==

Once the required dependencies are installed, you can install this
package in the standard place with the following commands in the
directory containing this README:

    python setup.py build
    sudo python setup.py install


== Developer mode ==

If you use pybliographer for your own developments and need to modify
pybliographer itself, you can run 

   sudo python setup.py develop

This will ensure that when you import Pyblio, you'll get the version
in _your_ working directory. No need to play with your PYTHONPATH
anymore.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks