I've run into a wall while trying to get some code to function after compiling it. I have already posted about this issue here: pyconsole but the more I dig into the problem, the more I'm starting to think it might be something to do with py2exe.

As explained in the above link, when I compile pyconsole with py2exe, the window loads up fine, but the console portion of it has ended and any interaction with the controls causes the window to lock up. I have dug into it a bit further since that post and I have noticed that when I run the script as-is, it loads the normal python.exe process in the task manager along with another python.exe and a cmd.exe process. When compiled, the other two processes do not run, which seems to be why the console does not load up correctly. I have fiddled around with those two processes (the second python.exe & cmd.exe) and noticed taht when I kill them manually, I recieve the same error and reaction when trying to use the gui.

So basically I need to know why the two processes (2nd python.exe & cmd.exe) are being supressed from loading after I compile the code.

Easiest way to reproduce this error is to download the pyconsole files from the above link, grab & run the basic setup.py file I posted along with it. Please note that I have tried many variations of the py file, although I am still not sure if there is something I am missing in my file that might be causing this issue.

Thanks to all that can help!