Actually, sorry for the spam. I seem to have solved it. There was no run.exe in that directory. But as I looked in site-packages, I saw I had multiple installs of py2exe, one with just the py2exe dir name which did have the run.exe within. I deleted all but that one and it worked.

Kelsey Golden

On Sat, Jul 16, 2011 at 9:19 PM, Kelsey Golden <> wrote:

I am following the tutorial (compiling a "hello, world" app) and am getting the following error when I try to run my make script:

C:\py2exetutorial>python py2exe
running py2exe
*** searching for required modules ***
*** parsing results ***
creating python loader for extension 'unicodedata' (C:\Python27\DLLs\unicodedata.pyd -> unicodedata.
creating python loader for extension 'select' (C:\Python27\DLLs\select.pyd -> select.pyd)
creating python loader for extension '_hashlib' (C:\Python27\DLLs\_hashlib.pyd -> _hashlib.pyd)
creating python loader for extension 'bz2' (C:\Python27\DLLs\bz2.pyd -> bz2.pyd)
*** finding dlls needed ***
Traceback (most recent call last):
  File "", line 9, in <module>
  File "C:\Python27\Lib\distutils\", line 152, in setup
  File "C:\Python27\Lib\distutils\", line 953, in run_commands
  File "C:\Python27\Lib\distutils\", line 972, in run_command
  File "C:\Python27\lib\site-packages\py2exe-0.6.9-py2.7-win32.egg\py2exe\", line 243, i
n run
  File "C:\Python27\lib\site-packages\py2exe-0.6.9-py2.7-win32.egg\py2exe\", line 305, i
n _run
    dlls = self.find_dlls(extensions)
  File "C:\Python27\lib\site-packages\py2exe-0.6.9-py2.7-win32.egg\py2exe\", line 389, i
n find_dlls
  File "C:\Python27\lib\site-packages\py2exe-0.6.9-py2.7-win32.egg\py2exe\", line 1064,
in find_dependend_dlls
    bin_depends(loadpath, images + [sys.executable], excludes_use)
  File "C:\Python27\lib\site-packages\py2exe-0.6.9-py2.7-win32.egg\py2exe\", line 1438,
in bin_depends
    for result in py2exe_util.depends(image, loadpath).items():
py2exe_util.bind_error: (2, 'The system cannot find the file specified', 'C:\\Python27\\lib\\site-pa

I did not find anyone with the same problem on google. Any ideas?


Kelsey Golden