Just to add... I'm getting the exact same problem on OSX as well, with py2app... without  PySide.QtUiTools, py2app works like a charm too!!

I think I'll drop this error on PySide forum as well...

blog   home

On Wed, Aug 24, 2011 at 1:30 PM, Hradec <hradec@hradec.com> wrote:
I set the exe as console but still not error output... just crashes. 

I went into windows log, and found this:

Faulting application name: test.exe, version:, time stamp: 0x49180192
Faulting module name: PYTHON27.DLL, version: 2.7.1150.1013, time stamp: 0x4cf1405f
Exception code: 0xc0000005
Fault offset: 0x00008876
Faulting process id: 0x2fd8
Faulting application start time: 0x01cc629bee40e219
Faulting application path: D:\Dropbox\gabiguga_hradec.com\snygro\software\github\chemshapes\host\dist\test.exe
Faulting module path: D:\Dropbox\gabiguga_hradec.com\snygro\software\github\chemshapes\host\dist\PYTHON27.DLL
Report Id: 2c246c91-ce8f-11e0-b49f-485b396f7f70

this is my setup.py:

import os, sys

if sys.platform == 'darwin':
    from setuptools import setup
    from distutils.core import setup
    from glob import glob

    import py2exe

    # pack MSVC libs for python 2.7
    data_files = [
        ("Microsoft.VC90.CRT", [os.path.abspath('./__debug_env_w32/Python27/msvcr90.dll')]),
        ("Microsoft.VC90.CRT", [os.path.abspath('./__debug_env_w32/Python27/msvcp90.dll')]),

        options = {'py2exe': {
            "includes": [
            ], "excludes": [], "skip_archive":False, 'optimize': 2, "unbuffered": True, "bundle_files":2 }
        console = [{'script': "test.py"}],
        zipfile = "shared.lib",

again, if I comment  "import PySide.QtUiTools as QtUiTools" out of my test.py, it works like a charm... 

It's really annoying having to switch to converting the .ui to .py... I really love the .ui mechanism... but I'm starting to think that will be my only option.

blog   home

On Tue, Aug 23, 2011 at 11:42 PM, Werner F. Bruhin <werner.bruhin@free.fr> wrote:
On 08/23/2011 01:57 AM, Hradec wrote:
> If I include PySide.QtUiTools into my script, the .exe generated by
> py2exe crashes without any message or anything... just loads and exists.
> It works fine if I run it as a script...
> Is this a known problem? Am I missing something to include in my
> setup.py to get it working correctly?
> As I couldn't find any info on the web about this, I'm asking here...
> any help would be really appreciated!
Haven't used PySide and py2exe but here a couple of tips which might help.

Instead or in addition of using the "windows" create a "console" app for
your PySide script.

Run the "console" one from a command prompt, you might see some
exception you don't see when using "windows".

Include an entry for the PySide package in the "packages" option to
force py2exe to include all of PySide.


EMC VNX: the world's simplest storage, starting under $10K
The only unified storage solution that offers unified management
Up to 160% more powerful than alternatives and 25% more efficient.
Guaranteed. http://p.sf.net/sfu/emc-vnx-dev2dev
Py2exe-users mailing list