Hi,
We got this sorted out.

For all of you that may have seen problems with importing zope.interface, or zope, from py2exe. py2exe goes about finding things from the roots up, first trying to import zope, then zope.interface. In some installations anyway, zope is not really a full-fledged package, although zope.interface is. The solution is to place an empty __init__.py in the zope directory. We saw this problem googling in a bunch of forums, but never did notice the answer posted anywhere, so maybe this'll help someone. Thanks to Ray for figuring this out.
Ken

On Fri, Dec 17, 2010 at 9:51 AM, Ken MacDonald <drken567@gmail.com> wrote:
My py2exe seems to be completing successfully, but when I run I get this traceback. I've tried explicitly importing the module in my setup.py, but that fails. Running from the cmd line python interpreter, I can import both zope and zope.interface successfully; zope is a built-in and zope.interface is in site-packages. Suggestions appreciated!
Ken

Traceback (most recent call last):
  File "cwp_server.py", line 18, in <module>
  File "twisted\internet\reactor.pyc", line 37, in <module>
  File "twisted\internet\selectreactor.pyc", line 17, in <module>
ImportError: No module named zope.interface