Hi,

On XP SP2, with Python 2.6.4 and py2exe0.6.9, I built the 'simple' sample in the py2exe\samples folder (after rounding up msvcp90.dll and msvcr90.dll) and moved the entire contents of the resulting dist directory to another computer without python installed, running XP SP3. I also added msvcr90.dll to the dist directory, since apparently nothing works without it.

The resulting executables won't run on the XP SP3 computer without python. They do run on the XP SP2 computer with python.

There seems to be a dependency on python. What am I doing wrong?

Rick King
Southfield MI

BTW: I modified the test_wx.py to import wx instead of import from wxPython:

import wx

class MyFrame(wx.Frame):
    def __init__(self, parent, ID, title, pos=wx.DefaultPosition,
                 size=(200, 200), style=wx.DEFAULT_FRAME_STYLE):
        wx.Frame.__init__(self, parent, ID, title, pos, size, style)
        panel = wx.Panel(self, -1)

        button = wx.Button(panel, 1003, "Close Me")
        button.SetPosition(wx.Point(15, 15))
        wx.EVT_BUTTON(self, 1003, self.OnCloseMe)
        wx.EVT_CLOSE(self, self.OnCloseWindow)

        button = wx.Button(panel, 1004, "Press Me")
        button.SetPosition(wx.Point(15, 45))
        wx.EVT_BUTTON(self, 1004, self.OnPressMe)

    def OnCloseMe(self, event):
        self.Close(True)

    def OnPressMe(self, event):
        x = 1 / 0

    def OnCloseWindow(self, event):
        self.Destroy()

class MyApp(wx.App):
    def OnInit(self):
        frame = MyFrame(None, -1, "Hello from wxPython")
        frame.Show(True)
        self.SetTopWindow(frame)
        return True

app = MyApp(0)
app.MainLoop()