Sorry for the late reply but the error went away when I ran it using "Run As administrator" function . Thanks to whoever suggested using that. It worked!

Werner F. Bruhin wrote:

Astan Chee wrote:
Werner F. Bruhin wrote:
Astan Chee wrote:
Werner F. Bruhin wrote:
I did that before I move my dev machine to Win 7 and had no problems.
I now py2exe my app in Win 7 and deploy to Win 7, Vista and XP without 
any problem.

"Access is denied" points to a permission issue and I don't think this 
is caused by py2exe.

How do you install it on Win 7?  Are you making sure that nothing user 
writable is installed into "program files" folder - this is not 
permitted as of Vista already.
What is the answer to the above?
I don't install on windows 7. I install python (and everything else in 
windows XP) and then build the .exe and then copy it (and the entire 
dist and build folder) over to a windows 7 machine. When I double click 
the .exe, nothing happens. When I try to run it from a cmd terminal, it 
says Access is Denied, and nothing else. I didn't copy it to a program 
files folder, but another generic folder that has correct and necessary 
I havent tried it on a vista machine because I don't have one to test it on.
You don't need the build folder.

Is any app log file generated when you run the .exe?

I most of the time generate two exe's one using the windows option and 
the other using the console option.

In a case like yours I would then try to run the console option on the 
Win 7 machine from a cmd.exe window.  Hopefully you will see better/more 
meaning full error.

Can you try to build the test script from the following wiki page?

How did this go for you?  Could you build this little test script on 
your XP machine and then run it on your Win 7 machine?


Return on Information:
Google Enterprise Search pays you back
Get the facts.
Py2exe-users mailing list