#2 data safe file from 1.2 not compatable w/ 1.3

release 0.1.3
closed-fixed
None
9
2004-02-12
2004-02-11
Anonymous
No

i have a pwsafe.dat file that was created w/ 1.2
if i use pwsafe 1.2 to access it, my passphrase works
if i use pwsafe 1.3 to access it, my passphrase does
not work (says it's invalid)

Discussion

  • Nicolas Dade

    Nicolas Dade - 2004-02-11
    • assigned_to: nobody --> ndade
     
  • Nicolas Dade

    Nicolas Dade - 2004-02-11

    Logged In: YES
    user_id=957363

    OK I reproduced this. The trouble is with i386 processors,
    and the trouble is with release 0.1.4.
    I'll track it down and release 0.1.4 tomorrow.

    I've put a test database at
    http://nsd.dyndns.org/pwsafe/test.dat with passphrase "abc".
    You can use to to sanity check your builds.

     
  • Nicolas Dade

    Nicolas Dade - 2004-02-11
    • priority: 5 --> 9
    • status: open --> open-accepted
     
  • Nicolas Dade

    Nicolas Dade - 2004-02-11
    • milestone: --> release 0.1.3
     
  • Nicolas Dade

    Nicolas Dade - 2004-02-12

    Logged In: YES
    user_id=957363

    Fixed in 0.1.4.

    I added a sanity check to the Makefile and a known-good
    database (test.dat, passphase "abc"). From now on you can

    make check

    to make sure your builds are ok.

     
  • Nicolas Dade

    Nicolas Dade - 2004-02-12
    • status: open-accepted --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks