I think it would be quite convenient to have separate
"name" and "receive" symbols for arrays. That way you
could specific a name with which you can send data to
that array, but that name would not have to be displayed.
Also, it would be handy to have a separate name and
receive when using $0- variables. The name would not
have to have the $0- in it, but the receive would.