#34 segfault in CCSD geometry optimzation with analytical grad

closed-out-of-date
nobody
None
5
2013-04-09
2011-09-13
No

The following input file crashes on psicode-3.4.0 (see also http://bugs.debian.org/641470\):

% 6-31G** H2O Test optimization calculation
psi: (
label = "6-31G** SCF H2O"
jobtype = opt
wfn = ccsd
reference = rhf
dertype = first
basis = "6-31G**"
num_threads = 4
memory = (2048 MB)
zmat = (
o
h 1 roh
h 1 roh 2 ahoh
)
zvars = (
roh 0.96031231
ahoh 104.09437511
)
)

Output (on x86-64):

The PSI3 Execution Driver
PSI3 will perform a RHF CCSD optimisation via analytic gradients.
The following programs will be executed:
input
REPEAT 40
cints
cscf
transqt2
ccsort
ccenergy
cchbar
cclambda
ccdensity
oeprop
transqt --backtr
cints --deriv1
optking --opt_step
END
psiclean

input
REPEAT 40
CYCLE 1
cints
cscf
transqt2
ccsort
ccenergy
cchbar
cclambda
ccdensity
oeprop
transqt --backtr
cints --deriv1
optking --opt_step

Command optking --opt_step was terminated with signal 11

When I try to run the above input on my ThinkPad (x86), I get:

The PSI3 Execution Driver

PSI3 will perform a RHF CCSD optimization via analytic gradients.

The following programs will be executed:

input
REPEAT 40
cints
cscf
transqt2
ccsort
ccenergy
cchbar
cclambda
ccdensity
oeprop
transqt --backtr
cints --deriv1
optking --opt_step
END
psiclean

input
REPEAT (40)
CYCLE 1
cints
cscf
transqt2
ccsort
ccenergy
cchbar
cclambda
ccdensity
oeprop
transqt --backtr
Segmentation fault
cints --deriv1
Segmentation fault
optking --opt_step
Segmentation fault
CYCLE 2

and segfaults thereafter. Not sure if this is a Debian-related problem or possibly reproducable by you?

Discussion

  • Michael Banck

    Michael Banck - 2011-09-13

    Hrm, weird.

    If I put the above input into input.dat, and run the commands manually as indicated by the driver, it works fine.

     
  • Michael Banck

    Michael Banck - 2013-04-08

    It turned out this was due to a Debian-specific patch

     
  • Michael Banck

    Michael Banck - 2013-04-08
    • status: open --> closed-invalid
     
  • T. Daniel Crawford

    • status: closed-invalid --> closed-out-of-date