Anonymous - 2012-10-18

Lista de cosas por agregar o mejorar en PSeInt para morir tranquilo =). No! la verdad es que voy ha dictar un curso de programación básica y quiero utilizar esta herramienta de aprendizaje, pero con la siguiente lista espero aportar en la evolución del proyecto =)

I: En la ventana de Diagrama de flujo

A: Opciones de simple cambio

0: Adherir icono, podría ser el mismo icono de pseint pero con una ruedita dentada indicando generación del diagrama

1: La barra de estado inferior agregar opción de colocar arriba o abajo, (por problemas de postura para mantener la vista siempre arriba es mejor ubicar la barra de tareas de Windows arriba) creo haber visto algunos sistemas operativos por defecto con la barra de tareas en la parte superior

2: si en el código contiene comentarios entonces una opción al crear el diagrama de flujo, seria que al clic derecho sobre los símbolos (rombos, elipses, cuadrados, etcétera) se despliegue el comentario o en una esquina una pequeña marca para expandir los comentarios

II: En la ventana principal

A: Opciones de simple cambio

0: Adherir icono, de “opciones del lenguaje” en la barra de herramientas

B: Opciones mas complejas a implementar

1: Tema de fondo, posibilidad para cambiar por ejemplo colores, tipo de texto, etc.

2: Exportar a HTML

Lo siguiente es lo más importante

Al generar el diagrama de flujo y salvarlo, me cambia en ciertas partes el código por ejemplo si un cadena de texto estaba con “Hello” la convirtió a ‘Hello’ , Algunos nombres cambiaron de formato minúsculas creo que esto es debido a los perfiles por esta razón sugiero que se debe mejorar las “opciones del lenguaje” generando un archivo de configuración donde el usuario escoja cada item como se explica en el punto 3:

3: Adherir una ventana con diferentes campos, donde el usuario escogería con que tipo de símbolos quiere trabajar por ejemplo

Cadena de texto: símbolos a utilizar ( “”, ‘’ )

Concatenación (unión) de cadenas: símbolos a utilizar ( +, (coma), (vacío) )

Asignación de valores: símbolos a utilizar ( <-, ->, =, := )
Los símbolos ->, y := son utilizados por ejemplo en el Basic de las calculadoras Texas Instruments y Hewlett Packard

PALABRAS DE OPERADORES RELACIONES

Operador( x es menor que y ): símbolos a utilizar ( <, Es Menor Que )

Operador( x es mayor que y ): símbolos a utilizar ( >, Es Mayor Que )

Operador( x es igual que y ): símbolos a utilizar ( ==, Es igual Que )

Operador( x no es igual que y ): símbolos a utilizar ( ==, =/=, !=, <>, No Es igual Que )

Operador( x menor que o igual a y ): símbolos a utilizar ( <=, Es Menor Que O Igual a )

Operador( x mayor que o igual a y ): símbolos a utilizar ( >=, Es Mayor Que O Igual a )

OPERADORES LÓGICOS

Operador( x AND y ): símbolos a utilizar ( &,^, Y, CONJ ) // Conjunción

Operador( x OR inclusivo y ): símbolos a utilizar ( |, O, DISY ) // Disyunción

Operador( x OR exclusivo y ): símbolos a utilizar ( ^,Oexc )

Operador( NOT x ): símbolos a utilizar ( !, ¬, ~, NO, NEG ) // Negación

Verdad: símbolos a utilizar ( 1, VERDAD )

Falso: símbolos a utilizar ( 0, FALSO )

Operador( DesplazamientoDerecha x ): símbolos a utilizar ( >>, bitDer )

Operador( DesplazamientoIzquierda x ): símbolos a utilizar ( <<, bitIzq )

Ejemplo en C++ para bitDer, bitIzq, Oexc
int a, b, c, d;

a = 0xd3; // = 0b11010011 = 211
b = 0xf5; // = 0b11110101 = 245
c = 0x1e; // = 0b00011110 = 30

d = c << 3 // 00011110 << 3 = 11110000 ->; 0xf0 = 240
d = a >> 4 // 11010011 >> 4 = 00001101 ->; 0x0d = 13

OTROS

Operador( x MODULO y ): símbolos a utilizar ( %, MOD )

Operador( x es par? ): símbolos a utilizar ( (% 2 = 0), (MOD 2 = 0) )

Operador( x es impar? ): símbolos a utilizar ( (% 2 > 1), (MOD 2 > 1) )

Subíndices de los arreglos: símbolos a utilizar ( (Corchetes), (), {} )

Iniciar índices de los arreglos: Iniciar en ( 0, 1 )

Variables o nombre identificadores: ( SIEMPRE EN MAYÚSCULAS, siempre en minúsculas, )

Nombres del psedocodigo: ( SIEMPRE EN MAYUSCULAS, siempre en minúsculas, Inicial en Mayusculas )

Nombres compuestos del psedocodigo: ( Unir, Separar )
ejemplo Fin Si, Fin Para / FinSi, FinPara

Tipos de datos enteros: símbolos a utilizar ( Como Enteros, (vacío) )

Fin de sentencias: símbolos a utilizar ( (;), (:), (vacío) )

Comentario: símbolos a utilizar ( //, / /, #, ©, // \ )

Los símbolos © teclas rápidas (ALT+169) son utilizados por ejemplo en el Basic de las calculadoras Texas Instruments, demás la C circunscrita coincide con el inicio de la palabra Comentario.

Formateando código y al exportar a lenguaje C++: ( (Separar objetos de las expresiones), (Juntar objetos de las expresiones), NO formatear )

Visualizar expresiones separadamente hace mas fácil la lectura
Ejemplo:
cant_discos( t2 ) <- cant_discos( t2 ) + 1; // Separado

cant_discos(t2)<-cant_discos(t2)+1; // Junto

Estructura Según: ( (Incluir variable de comparación), (Vacío))

Comparar la expresión se acerca mas al lenguaje humano que simplemente el numero y dos puntos
Por Ejemplo:

Según Opción Hacer
Opcion == 1:
Total<- presupuesto*0.40;
Escribir "El monto que corresponde al Area de Ginecologia es de:", Total;

Opción == 2:
Total<-presupuesto*0.30;
Escribir "El monto que corresponde al Area de Traumatologia es de:", Total;

Opción == 3:
Total<-presupuesto*0.30;
Escribir "El monto que corresponde al Area de Pediatria es de:", Total;

FinSegun

Gracias

JF

 
Last edit: Anonymous 2012-10-22