MacOSX

khyros
2007-09-12
2013-04-22
  • khyros

    khyros - 2007-09-12

    I'm getting this error message when I try to compile Proxytunnel under MacOSX.
    I edited the makefile file and uncommented the Darwin entry and removed the two entries under proxyfile.o (mentioned on the Makefile.darwin thread) but still no success.

    cc -Wall -O2 -ggdb -DHAVE_GETOPT_LONG -DUSE_SSL -DSETPROCTITLE -DSPT_TYPE=2 -DDARWIN -c -o proxytunnel.o proxytunnel.c
    cc: installation problem, cannot exec `cc1': No such file or directory
    make: *** [proxytunnel.o] Error 1

    Any ideas how can I fix it?
    thanks

     
    • Cassini

      Cassini - 2007-10-11

      I am also trying to build proxytunnel using OS X 10.4.10, following the instructions in the makefile and also on the Makefile.darwin thread here.  I have commented out "CFLAGS += -DHAVE_GETOPT_LONG" (since as far as I know OS X is not a gnu-system), and uncommented the darwin line.  I have removed the strlcpy/strlcat lines as well.

      I recieve the following errors when I run the makefile:

      cc -Wall -O2 -ggdb -DUSE_SSL             -DSETPROCTITLE -DSPT_TYPE=2 -DREV= -DSO_REUSEPORT       -DDARWIN   -c -o proxytunnel.o proxytunnel.c
      proxytunnel.c: In function 'do_daemon':
      proxytunnel.c:263: warning: pointer targets in passing argument 3 of 'accept' differ in signedness
      ./getrev.sh: line 2: svn: command not found
      cc -Wall -O2 -ggdb -DUSE_SSL             -DSETPROCTITLE -DSPT_TYPE=2 -DREV= -DSO_REUSEPORT       -DDARWIN   -c -o base64

      The "./getrev.sh: line 2: svn: command not found" repeats for every source file.  Should I be building this in a particular directory?  Am I missing a component of gcc?  Any help is much appreciated.

       
      • Mark Janssen

        Mark Janssen - 2007-10-11

        The getrev.sh shouldn't bother you, and compilation should succeed anyway afaik. It's only purpose is to get the build-number from subversion.

        Did you end up with a proxytunnel binary ?

         
    • Cassini

      Cassini - 2007-10-21

      To Mark Janssen -

      Thanks for the response.  No, the make process exits on an error before the linking step.  Another error that pops up and that I didn't see the first time around is:

      cmdline.c: In function 'cmdline_parser_print_version':
      cmdline.c:38: error: parse error before ',' token

      After reading the function cmdline_parser_print_version and realizing it has no function other than to print a version statement, I deleted the contents of the function and tried make again.  All worked fine.  Just looking at the function itself I couldn't see the parse error, but I'm not a great programmer.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks