change language

Bug List
Anonymous
2012-09-03
2016-05-31
  • Anonymous - 2012-09-03

    My Windows system default language is set to Dutch and my location is Netherlands, even though all menu's and everything is in English. However, ProjectLibre opens in Dutch. Is it possible to change the settings for the language of ProjectLibre?

     
  • Laurent Chretienneau

    Yes some menus aren't translated yet.
    To change the language, you can create the file [UserDir]/ProjectLibre/openproj.conf (on Mac, or Linux it's [UserDir]/.projectlibre/openproj.conf). Insert the line "locale=[your language code]". For example "locale=en".
    Note that in the next releases (>1.5_beta3), openproj.conf will be renamed to projectlibre.conf

     
    Last edit: Laurent Chretienneau 2012-09-03
  • Anonymous - 2012-09-04

    Hi,
    I tried this method but it didn't work. I created the file in the same folder as projectlibre.jar is located (in my case E:\projectlibre-1.5_beta3\openproj.conf) and also tried in a folder inside of that one (E:\projectlibre-1.5_beta3\UserDir\ProjectLibre). I tried to create the file with or without quotation marks around the locale=en statement. I also tried both openproj.conf and projectlibre.conf. In all cases, projectLibre would open in Dutch. Any idea what could be happening?

     
  • Laurent Chretienneau

    Hi,
    ProjectLibre directory has to be in your user home directory. So ProjectLibre should be at the level has "My Documents" for example. If it doesn't exist, create it. Inside this directory create a file name "openproj.conf" for beta3 (It will be "projectlibre.conf" in future releases. Then in this file put the line:
    locale=en

     
  • Anonymous - 2012-09-10

    @Laurent: I am a lay in this field, so I need baby steps help. When the "new" button is clicked, several file types can be created, like txt, word etc. What file type should originally be used to create a file with the name openproj.conf? If the file type is not present in the list when clicking upon "new", where and how should it be added?

    Has a anyone else found other solutions?

     
  • Laurent Chretienneau

    You can you use the Command Prompt. It should open in your home directory. To create the file type:
    echo "locale=en" > ProjectLibre\projectlibre.conf

     
  • Anonymous - 2012-10-24

    your trick is not working ... I am unable to change the language of the interface.

     
  • Anonymous - 2012-11-15

    Thanks, it worked for me:

    C:\Documents and Settings\MYUSER\ProjectLibre\projectlibre.conf

     
  • Anonymous - 2013-08-01

    None of the above have helped. I tried creating a folder in C:\User\MYUSER\ called "Project Libre", and created a txt file called projectlibre.conf with the text above. However, the language setting did not change.

     
  • Anonymous - 2013-10-24

    Thanks for above hints - I just changed language and it worked out fine as follows:

    1. Create a new folder ProjectLibre in user home directory (same level as MyDocuments)
    2. Use command prompt: echo "locale=en" > ProjectLibre\projectlibre.conf
      (until here it did not work - but then:)

    3. open the newly created file projectlibre.conf (with an text editor program) and delete the quotation marks (" "). ... in other words - the quotation marks should not be written in the file. Save and Close - and next time opening ProjectLibre it opens in English.

    So far so good :-)

    However - now I have another issue. With the above steps I changed the language from German to English. And instead of Euro symbol the system now shows an awkward symbol - something like a little square. Does anyone now what this means? I would wish to keep Euros as the currency, while EN as the language setting. Anyone who can help???

     
  • Anonymous - 2013-11-06

    For similar ISO format in Poland Windows 8:
    type in cmd:
    cd %HOMEDRIVE%%HOMEPATH%
    echo locale=pl> ProjectLibre\projectlibre.conf

    Format: 13-11-06 08:00

     
    • Anonymous - 2014-12-08
      Post awaiting moderation.
    • Anonymous - 2016-05-31
      Post awaiting moderation.
  • Anonymous - 2014-05-13
    Post awaiting moderation.


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks