SBS 2003

Scale Man
2010-12-01
2012-11-13
  • Scale Man

    Scale Man - 2010-12-01

    Hello, i take it ]PO[ doens't work on SBS2003? :(

     
  • JPD-po-admin

    JPD-po-admin - 2010-12-02

    I suggest you try it (if you have not already).  That may be the fastest way to answer your own question.

     
  • Scale Man

    Scale Man - 2010-12-02

    Hi, i did try but none of the services - AOL etc appear in the Services list, and the error message suggests there are no services associated. Not sure whether this was a security thing or some thing to do with the version of SBS2003 im running.

     
  • Maurizio Martignano

    Dear all,
    I checked and found the same problems on a Windows SBS 2003 (win32 bit).
    SBS 2003 is not one of the certified platforms….
    Anyhow, the following sequence fixed the problems:
    1. Install ]po[ anyhow.
    2. install PostgresSQL manually and install all possible packages, add ons (use as user "postgres" and as password "Qwer.1234".
    3. Stop PostgreSQL.
    4. Copy the postgresql.conf file in the data folder of ]po[ wherevere you have installed PostrgreSQL (you should find the same data there).
    5. Start PostgreSQL
    6. Go into teh data folder of ]po[ end exec in sequence:
    cratedb -U postgres projop
    psql -U postgres projop < projop.sql
    7. Unistall Visual Studio 2010 Redistributable Package
    8. Find, load and install Visual Studio 2008 Redistributable Package
    9. Install again Visual Studio 2010 Redistributable Package.

    GOOD LUCK!!!!!

     
  • Ruth Cheesley

    Ruth Cheesley - 2011-03-05

    Couple of clarifications on the instructions above - I'm making a video of the process at the moment.

    1. Install ]po[ - it will fail when it gets to installing Postgresql - REMOVE the postgresql user from Active Directory Users & Computers>Users>postgresql
    2. install PostgresSQL manually and install all possible packages, add ons (use as user "postgres" and as password "Qwer.1234". you can do this using the file within yourPOdirectory>Software
    3. Stop PostgreSQL.
    4. Copy the postgresql.conf file in the data folder of ]po[ (into the same 'data' folder in the directory wherevere you have installed PostrgreSQL (you should find the same data there).
    5. Start PostgreSQL
    6. Go into teh data folder of ]po[ **(via command line) end exec in sequence:
    (this should be createdb) cratedb -U postgres projop
    psql -U postgres projop < projop.sql
    7. Uninstall Visual Studio 2010 Redistributable Package and any other packages installed (e.g. 2005)
    8. Find, load and install Visual Studio 2008 Redistributable Package (download via search engine)
    9. Install again Visual Studio 2010 Redistributable Package. (found in yourpodirectory>software)
    10. Start PO by going start menu>PO>start

    Hope this helps, feel free to give me a shout if you need a hand as I have several SBS 2003 test servers kicking around!

    Ruth
    **

     
  • Ruth Cheesley

    Ruth Cheesley - 2011-03-05

    Apologies for the lack of a closing bold tag - it seems i can't edit my post! :o

     
  • Rodel Baccay

    Rodel Baccay - 2011-03-21

    Hi,

    I was able to install the project-open to our windows server 2003. Now my question is how could a client pc connect to the database locally?
    I shared the whole folder of the project-open to the client pc to have an access to the internet shortcut, but it’s not working, we are newbie to this and we want to further test.

    We would appreciate your immediate help to our concern.

    rodel

     
  • JPD-po-admin

    JPD-po-admin - 2011-03-22

    RBACCAY,

    It sounds like you have P-O running successfully on your server.  Great.  Now to the clients… By 'connect… locally' I assume you mean that you have a PC on the same office network - all connected through a router or hub. 

    You do not need to worry about sharing folders at all.  If P-O and AOLSERVER is actually running OK on your server, connections will be made through your client's browser.

    If you just want LOCAL connections, you need to determine the local IP address of your P-O server.  It may be something like 192.168.2.101 (right?).   In the client's browser you just need to enter the server's IP address and the appropriate port number - the port that AOLSERVER is using - typically port 8000.   This is what you would type into the browser on the client

    http://192.168.2.101:8000   EXAMPLE

    Realize that the local IP address may be subject to change - say when the server is shutdown for a while and then reconnects to your network.  You will almost certainly want the server to use a fixed local IP address - that way the clients can save the URL to a Favorite list and it will always work - and you will be one step closer to enabling external connections to the server.

    JPD

     
  • user

    user - 2011-04-25

    Hi ,

    We are using Windows 2003 Server, Enterprise Edition, SP1 and seeing the same issue. Will above steps solve this problem too. As this is Production Server I am little hesitent, please guide.

    thanks,
    SKV

     
  • Maurizio Martignano

    Hello SKV.

    Yes I believe it will work.

    Ciao,
    Maurizio

     
  • Saulius Zilinskas

    Hello,
    I am trying to install project open to Windows server 2003 R2 Service pack 2. But I have stucked on point:
    "Go into teh data folder of ]po[ (via command line) end exec in sequence:
    (this should be createdb) cratedb -U postgres projop" - it gives error "createdb is not recognized as internal or external comand…" what can be wrong thanks Saulius

     
  • Terrance Crow

    Terrance Crow - 2011-05-02

    I haven't tried installing PO, AOLServer, and PostgreSQL under Windows yet, but the error you're getting suggests that the PostgreSQL binaries directory isn't in your PATH.

    Either you're trying to run the command from an MS DOS prompt that was running before the PostgreSQL installation happened, which means that the MS DOS session didn't see the PATH update, or the PATH update didn't happen.

    You could either add the PostgreSQL binaries directory to your PATH or you could include the full path in front of the createdb command (probably some directory under C:\Program Files\PostgreSQL, but I'm guessing).

    Hope this helps!

     
  • Saulius Zilinskas

    Hello, terrancecrow
    Thank you for your comment I tried to run the command in the C:\Program Files\PostgreSQL\8.2\bin folder and it executed the command. Looks like it has created the db. Looks like Postgresql is running AOL server is running just on client I am getting error "OpenACS Installation: Error". It looks like ]po[ is not listening to port 5423

     
  • Terrance Crow

    Terrance Crow - 2011-05-02

    First, have you checked this FAQ?

    http://www.project-open.org/documentation/faq_installation

    It references the error you've described.

    If that doesn't help, just to be sure I understand your setup, can you confirm this is how your installation is configured?

    Computer A is the server. It's running PostgreSQL, AOLServer, and Project Open.

    Computer B is the client. You tried to connect to Computer A's port 8000 (or 8443 if you've installed SSL). Instead of showing the Project Open login page, you get the OpenACS installation error.

    Is that correct?

    If so, could you do two things?

    First, include the full text of the error displayed in the browser.

    Second, look at Project Open's error.log and look for any errors.

    On Computer A, do you have a firewall installed? Something like Windows Firewall? If so, you may need to adjust what ports it allows in or out.

    Hope this helps.

     
  • Saulius Zilinskas

    1.Yes I have checked FAQ, and found no line TCP    127.0.0.1:5432         127.0.0.1:5432         LISTENING
    2. Yes you are correct I am getting error on client but the same is on server if I open address http://localhost:8000/. Full error message:

    OpenACS Installation: Error

    Thank you for installing the Open Architecture Community System (OpenACS), a suite of fully-integrated enterprise-class solutions for collaborative commerce. This is the OpenACS Installer which performs all the steps necessary to get the OpenACS Community System running on your server.
    Please read the Release Notes before proceeding to better understand what is contained in this release.

    RDBMS type could not be determined for any pool.

    The first step involved in setting up your OpenACS installation is to configure your RDBMS, correctly install a database driver, and configure AOLserver to use it. You can download and install the latest version of the AOLserver Oracle and PostgreSQL drivers from the OpenACS.org Software Page.

    Once you're sure everything is installed and configured correctly, restart AOLserver.

    gatekeepers@openacs.org
    3.  Errors on the error.log
    Warning: modload: could not load g:/project-open/bin/nspostgres.so: win32 error code: 126
    Error: dbdrv: failed to load driver 'postgres'
    Error: dbinit: no such default pool 'pool1'
    Error: Database API: RDBMS type could not be determined for any pool.
    Error: Bootstrap: RDBMS type could not be determined for any pool.
    02/May/2011:00:00:06] Error: nslog: rename(g:/project-open/servers/projop/log/projop.log, g:/project-open/servers/projop/log/projop.log.2011-05-02-00:00) failed: 'Invalid argument'
    Notice: nslog: opened 'g:/project-open/servers/projop/log/projop.log'
    Error: dbdrv: failed to load driver 'postgres'
    Error: dbinit: no such default pool 'pool1'
    Error: Database API: RDBMS type could not be determined for any pool.
    160-] Warning: modload: could not load g:/project-open/bin/nspostgres.so: win32 error code: 126
    Error: dbdrv: failed to load driver 'postgres'
    Error: dbinit: no such default pool 'pool1'
    4. No firewall is active

    Please suggest what I should trey to make it running.

    Saulius

     
  • Terrance Crow

    Terrance Crow - 2011-05-04

    I want to emphasize that I've never installed PO on SBS 2003, so I'm shooting in the dark here.

    Have you followed the suggestions earlier in this thread?

    If you have, then maybe these notes will help:

    First, "win32 error code: 126" means that the file wasn't found. So, either the shared object g:/project-open/bin/nspostgres.so isn't present or it's locked down too tight for the ID running AOLServer to see it. Can you double check that g:\project-open\bin contains npostgres.so?

    Is G: a network drive or a local drive? What's the OS of the server sharing that drive? If it's not Windows 2003 or later, there could be a permissions issue. A windows workstation often won't trust a non-Windows server (like Linux/Samba or OS X server).

    Hope this helps.

     
  • Saulius Zilinskas

    Yes I have followed suggestions earlier in this thread.
    g:\project-open\bin does not contain file npostgres.so. It can be copied from somewhere or completely new installation should be started?
    G is not network drive it is the same servers drive just it has raid 1+0 but maybe it it should not be an issue.

     
  • Terrance Crow

    Terrance Crow - 2011-05-04

    I think I agree that RAID 1+0 should not be the issue; but depending on who packaged Project Open for Windows and the decisions they made, drive G: might be an issue.

    Do you have nspostgres.so anywhere on your system? If so, you might try copying it to G:\project-open\bin. Trouble is, if it depends on other files, this still might not work.

    The real question is why is Project Open looking in G:\Project-Open\bin if its installation didn't put the files there?

    If you have npostgres.so on your system, where is it?

     
  • Maurizio Martignano

    Hello Sauzil,
    in case you still have problems, I may offer my professional support.
    Cheers,
    Maurizio Martignano

     
  • Saulius Zilinskas

    Hi terancecrow
    I could not find nspostgres.so file in the system. If G: is problem maybe it is worth to reinstall everything to C:  drive. Just I wanted to save storage on C. Is there any way to configure to store files on other drive after installation?

    Saulius

     
  • Saulius Zilinskas

    Hi,
    I have reinstalled project-open to C drive accrding to description above Now it is not starting at all not project open nor Aol-Server . Ons tarting po  it system writes can not find path specified. Smth related with permisions?

     
  • Terrance Crow

    Terrance Crow - 2011-05-05

    I think trying to install to C: was a good idea. I'm sorry to see it didn't work!

    Does PO under Windows have an installation log? I wonder if there are any clues there.

    At this point, since no one's spoke up to say that the installer is broken under Windows, I think it might be worthwhile to try to install to G: again. When you install, are you using either the administrator ID or an ID in the local administrator's group? If as you suspect the problem is NTFS permissions, then using the admin ID should at least allow full installation.

    In other words, I'm guessing that permissions may have caused the installation to not copy the shared object files like nspostgres.so.

    If the PO Windows installer doesn't leave a log, I'm not sure how to best troubleshoot that. I used to use something called FileMon to understand when permissions were a problem. I think Microsoft has rebranded that Process Monitor, and you can download it from Microsoft's Technet site.

    Or you might want consider finding local professional help! I don't want to waste your time with suggestions that won't work, but the only way I'll know if they work or not is try them; and I don't have an installation of SBS to use as a test bed.

    Hope this helps (though I'm decreasingly confident)!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks