#468 XML syntax error in build/build.xml file

v4.9
closed-fixed
None
5
2014-11-26
2013-03-20
F. Kooman
No

There is an issue with the build/build.xml in Proguard 4.9. The file contains invalid XML. The "classpath" should be closing tag...

diff -urN proguard4.9.orig/build/build.xml proguard4.9/build/build.xml
--- proguard4.9.orig/build/build.xml 2013-03-10 11:51:10.000000000 +0100
+++ proguard4.9/build/build.xml 2013-03-20 13:29:19.732059490 +0100
@@ -145,7 +145,7 @@



- <classpath>
+ </classpath>
</javac>

 <copy todir = "${classes}">

Discussion

  • Eric Lafortune

    Eric Lafortune - 2013-03-20

    Thanks, that was a stupid mistake. I've fixed it for the next release, 4.10beta1.

     
  • Eric Lafortune

    Eric Lafortune - 2013-03-20
    • labels: v4.9 -->
    • status: open --> open-fixed
    • milestone: v4.8 --> v4.9
     
  • Paul Sokolovsky

    Paul Sokolovsky - 2013-03-28

    Strange, hg tip didn't include this fix. Where's main proguard source code repo anyway?

     
  • Eric Lafortune

    Eric Lafortune - 2013-03-29

    The online repository contains snapshots of releases, for the sake of the Maven pom. My personal repository is not on-line. It has a different structure and junk that isn't intended for public consumption.

     
  • Eric Lafortune

    Eric Lafortune - 2013-09-02
    • status: open-fixed --> closed-fixed
    • assigned_to: Eric Lafortune
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks