Shortcut assignment doesn't work in Indigo?

2011-11-27
2012-11-10
  • Nobody/Anonymous

    Assigning short cut keys to macros, doesn't seem to work in Indigo (eclipse
    3.7). The same assignment works well under Helios (3.6).
    Ideas?

     
  • Ernest

    Ernest - 2011-11-28

    No. I'll give it a try in the next couple of days and see if I can reproduce.
    I assume you are using the latest version of the plugin (from the update
    site)?

     
  • Nobody/Anonymous

    Yep. Using version 0.3.4.
    Thanks

     
  • Ernest

    Ernest - 2011-12-01

    Hmm…I've tried this in 3.7.1, and I've sometimes (but not consistently) seen
    the command fail to work properly when mapped to a key. Out of curiosity, if
    you map a key, confirm it doesn't work, then bounce Eclipse and try again,
    does it work then? As I said, I've had the problem intermittently, but so far
    it has resisted debugging.

     
  • Ernest

    Ernest - 2011-12-01

    Okay, I have noticed that if the key is already mapped to a command, I get a
    warning in the error log like this:
    "A handler conflict occurred. This may disable some commands."
    Removing the conflicting command doesn't correct the situation during the
    session. However, restarting Eclipse after removing the other command makes
    the new keymapping work again.

    I'm not sure if this is the same thing you are running into. I'm also not sure
    if this behavior is different from Eclipse 3.6.

     
  • afer

    afer - 2011-12-01

    Works now! Thanks for your help!

     
  • Ernest

    Ernest - 2011-12-01

    Interesting. So you were running into the same problem I saw with having
    conflicting commands for the same keystroke? I tried in 3.6, and I don't think
    I saw the problem, so it's probably a change under the covers. It sounds like
    you have a workaround. I will take a look at some point to see if I can fix
    what's going on, but it may be beyond my control.

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks