machs - 2007-07-21

Installed Debian Etch network-distribution (+desktop=Gnome) on

ASUS M2NPV-MX (nf430) with AMD64X2 AM2 3800+ EE
MAC Adress: 01-02-03-04-05-06

(There is no PCI0 entry in /proc/acpi/wakeup)

Installed Ethtool, changed in /etc/init.d/halt : NETDOWN=yes to NETDOWN=no

Set eth0 interface:
  ethtool –s eth0 wol g
  ethtool –s eth0 speed 100
  ethtool –s eth0 duplex full
  ethtool –s eth0 autoneg off
eth0 LEDs link/100Mb

shut down debian
eth0 LEDs link/100Mb

----------
Sending wol with MAC: 010203040506 no reaction, no startup!
Sending wol with MAC: 060504030201 (reverse order!) starting up (funny isn’t it?)

----------
Setting (Gnome) “Preferences”->”Power Management” and then setting “Hibernate” = Suspend to disk
Sending wol with MAC: 010203040506 starting up
Sending wol with MAC: 060504030201 (reverse order!) starting up

----------
Installed kpowersave (0.6.2)
Shutdown
Sending wol with MAC: 060504030201(reverse order!) starting up
----------
Suspend to disk with kpowersave
Sending wol with MAC: 010203040506 no reaction, no startup!
Sending wol with MAC: 060504030201 no reaction, no startup!
----------
Start with Buttom
Shutdown
Sending wol with MAC: 010203040506 no reaction, no startup!
Sending wol with MAC: 060504030201 (reverse order!) starting up

I want to run Debian with KDE and kpowersave (inactivity shutdown), after Suspend to disk I want to use wol to start the server, but exactly this does not work. Wake up on RTC works perfect. Does anyone has any ideas?