SourceForge has been redesigned. Learn more.
Close

Emails truncated

Thomas
2013-08-29
2013-08-29
  • Thomas

    Thomas - 2013-08-29

    I'm running Postfix 2.0.19, dovecot 2.0.19, amavis,clamav and spamassassin on Ubuntu 12.04. Having this problem where some emails are truncated in the body. This problem is intermittent where the the same person can send 2 mails to us and one is ok but the other one is truncated. If we ask them to resend the email, what we receive is still the same, ie truncated.
    Anybody encounter this before or can point to me on where to look for the solutions? The only common thing I can find is that those truncated mail comes with attachment and the attachment are gone too.
    Example on the body of the mail:-

    -----Original Message-----
    From: Service & System Integration Division [mailto:sdc@aa.com.sg]
    Sent: 29 August 2013 10:32
    To: Operations Dept
    Cc: General;
    Subject: Re:NAVIGATIONAL ECHO SOUNDER PRINTER SA

    Dear Mr. Sir,

    Please refer to attach Furuno Information for rectification of this proble


    Thanks
    Tom

     
  • Simon Hobson

    Simon Hobson - 2013-08-29

    This isn't a general Postfix support forum - it's for support fo the Postfix Admin package which manages virtual domains/mailboxes for Postfix using a PHP web GUI and MySQL backend.

    You'll probably get a better response over at postfix.org.

     
  • Thomas

    Thomas - 2013-08-29

    Thanks for the info. I've did some searching and the solution seems to be adding the following code into /etc/postfix/main.cf:
    disable_mime_input_processing = yes
    disable_mime_output_conversion = yes

    Just in case somebody else stumble into this.

     
  • GingerDog

    GingerDog - 2013-08-29

    So the problem is that Postfix was performing some sort of mime processing/parsing, and the content was somehow invalid?

    (Just curious)

     
  • Christian Boltz

    Christian Boltz - 2013-08-29

    From reading man 5 postconf, I'd say that the mime processing is something that is needed for some servers (if they don't support 8bit mails), so disabling it (by setting the disable_... = yes parameters) could break things for some recipients for outgoing mail.

    Please discuss your problem at postfix.org - either you have a very strange configuration or there's a bug somewhere. (I tend to say "strange configuration" because I never heard of a similar problem before, but nevertheless you should check it.)

     

Log in to post a comment.