Login Super admin says credentials are incorecct

2013-04-16
2013-04-17
  • Thomas Standaert

    Hello.
    I'm kinda a newbie to postfixadmin, and this question may sound stupid, but it gets me a bit crazy here.
    I followed a tutorial (http://www.exratione.com/2012/05/a-mailserver-on-ubuntu-1204-postfix-dovecot-mysql/) on a virtual machine, and it worked. I decided it to bring it online by using a vps of ovh.net.
    I followed it, except of step 4, the hostname changes, and get the following problem:
    After I created the super admin account by running the form from setup.php, I try to login, but het the error message "Your email address or password are not correct."

    On the setup.php, I get
    Running software:

    PHP version 5.3.10-1ubuntu3.6
    Apache
    Checking for dependencies:

    Magic Quotes: Disabled - OK
    Depends on: presence config.inc.php - OK
    Checking $CONF['configured'] - OK
    Depends on: MySQL 3.23, 4.0 - OK
    Depends on: MySQL 4.1 - OK (change the database_type to 'mysqli' in config.inc.php!!)
    Testing database connection - OK - mysql://mail:xxxxx@localhost/mail
    Depends on: session - OK
    Depends on: pcre - OK
    Depends on: multibyte string - OK
    Depends on: IMAP functions - OK
    Everything seems fine... attempting to create/update database structure

    Database is up to date

    I suspect there's a database connection problem. The admin table in the database stays empty. Mysql.err and mysql.log stay empy. Changing the database_type to mysqli doesn't change anything.
    config.inc.php is the default file, except the changes from the tutorial.
    My hostname and domainname in /etc/hosts are configured not as localhost, but as the ipaddres of the server, done by ovh.net
    Also, which log files does postfix use, if any?
    Thanks in advance for the help.

    EDIT: A simple php file to connect to the mail database seems to work with the mail and mailpassword, so seems it's not a connect problem after all with the database?

     
    Last edit: Thomas Standaert 2013-04-17
  • Thomas Standaert

    Nevermind, seems I was really tired yesterday, and seemed to miss the "create superadmin account" right in front of my eyes. Worried like 5 hours on this ^^".
    Solved then.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks