Domain issues

  • ovencleaner

    ovencleaner - 2009-01-07

    Running Postfix Admin, MySQL, Postfix.

    I am having serious problems with the admin interface. I cannot add new domains with it when logged in as admin.

    The domain list shows up as:

    That is a lie, because when I run

    mysql> SELECT * FROM domain;
    | domain          | description     | aliases | mailboxes | maxquota | quota | transport | backupmx | created             | modified            | active |
    | ALL             |                 |       0 |         0 |        0 |     0 | NULL      |        0 | 0000-00-00 00:00:00 | 0000-00-00 00:00:00 |      1 |
    | | |       0 |         0 |        0 |     0 | virtual   |        0 | 2009-01-07 00:36:02 | 2009-01-07 00:36:02 |      1 |

    I cannot add email accounts because It will not let me select a valid domain!

    This problem is incredibly frustrating, I have been on google for over 8 hours with no avail.

    It seems like it is just ignoring my domain, and calling it "ALL"

    Please help!

    • Simon Hobson

      Simon Hobson - 2009-01-07

      I'd be inclined to take a backup of the database (or table) and delete that "ALL" record. I'm fairly sure I don't have one in the system I run at work.

    • ovencleaner

      ovencleaner - 2009-01-07

      Deleted it, now just nothing shows up....

      This is what happens when I try to look at the domain list:

      090107 16:20:08     245 Connect     postfix@localhost on
                          245 Query       SET CHARACTER SET utf8
                          245 Query       SET COLLATION_CONNECTION='utf8_general_ci'
                          245 Init DB     postfix
                          245 Query       SELECT domain.domain, domain_admins.username FROM domain
            LEFT JOIN domain_admins ON domain.domain=domain_admins.domain
            WHERE domain_admins.username=''
            AND domain.backupmx=0
            ORDER BY domain_admins.domain

      There was a duplicate domain admin but I deleted it.

    • ovencleaner

      ovencleaner - 2009-01-08

      Ok guys, i restarted postfix, got past that bug rebuilt the database, but I have a new problem

      First of all after creating a mailbox, any message to it geneates this:

      postfix/virtual[24622]: EC3501EC57A: to=<>, relay=virtual, delay=1040, delays=1040/0.05/0/0.05, dsn=4.3.5, status=deferred (mail system configuration error)

      Thank you for your help.

    • GingerDog

      GingerDog - 2009-01-08


      You should definately have an 'ALL' domain entry - this is used to indicate that an admin is a super-admin (and not just an admin for one particular domain).

  • Guilherme Silva

    Guilherme Silva - 2011-04-13

    I have the same issue…

  • Christian Boltz

    Christian Boltz - 2011-04-13

    gsasantos: This discussion thread is more than two years old, and lots of things have changed in the meantime (including the PostfixAdmin version - like in this discussion is not old, it's ancient already ;-))
    Additionally, more than one problem was discussed here, even if it they might sound like follow-up problems. This also means that "I have the same problem" is like going to the doctor and saying "I feel pain, but I won't tell you where" ;-)

    Please start a new topic and describe your problem (including the relevant details) there.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks