postfixadmin-2.3rc4

piaakit li
2009-06-01
2013-06-22
  • piaakit li

    piaakit li - 2009-06-01

    anybody know how to fix below error ?

    Error: There is no database support in your PHP setup
    To install MySQL 3.23 or 4.0 support on FreeBSD:

    Please edit the $CONF['database_*'] parameters in config.inc.php.

    DEBUG INFORMATION:
    MySQL 3.x / 4.0 functions not available!
    database_type = 'mysql' in config.inc.php, are you using a different database?

    Error: Depends on: multibyte string - NOT FOUND
    Warning: Depends on: IMAP functions - NOT FOUND
    To install IMAP support, install php5-imap

     
    • GingerDog

      GingerDog - 2009-06-01

      Ensure that 'php -m' lists mysql; until it does, you won't get very far.
      If you have mysqli installed (and not mysql) then you can use this instead.

       
    • piaakit li

      piaakit li - 2009-06-05

      what do u mean of Ensure that 'php -m' lists mysql, edit from config.inc.php file ?

       
    • GingerDog

      GingerDog - 2009-06-05

      Run, on the command line : 'php -m' - this will list modules which are installed for PHP... one of these should by MySQL.

      The error message indicates that you haven't (for example) installed the php5-mysql package, or -if you have- it's not set to load (see php.ini).

      For a further check, create a page called e.g. phpinfo.php containing "<?php phpinfo();"

      This should list various bits about PHP - one being what modules are installed and available.

       
  • Charlton Nguyen

    Charlton Nguyen - 2013-06-22

    i was able to get through this by editing

    nano /etc/apache2/php5/php.ini

    and adding in

    extension=mysql.so

    save and restart apache2 service.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks