#279 UTF-8 displayed as ISO-8859

v2.3.5
closed-fixed
nobody
4
2013-03-24
2012-10-09
No

Hi,

I installed ubuntu's package (http://archive.ubuntu.com/ubuntu/pool/universe/p/postfixadmin/postfixadmin_2.3.5-2_all.deb) and configured it to use apache2 and postgresql. The database was created OK using UTF-8. I enter accented characters and they're properly handled (I can check this using phppgadmin). However, when I browse domains or users whose names or descriptions have accented characters, they show up as 2 weird characters (this is what normally happens when UTF-8 chars are interpreted as ISO-8859-X).

If I try to edit the name in postfixadmin, the field to be edited displays OK. The problem is when it is being "shown".

Using stock ubuntu server 12.04

Discussion

  • Mariano Absatz

    Mariano Absatz - 2012-10-09
    • priority: 5 --> 4
     
  • ColdSmile

    ColdSmile - 2012-10-13

    htmlentities()
    The default value for the encoding parameter was changed to UTF-8 since 5.4.0

     
  • Mariano Absatz

    Mariano Absatz - 2012-10-13

    I see... the problem is that I'm using quantal's .deb in precise (which has php 5.3.1).

    I edited a couple of source files and fixed it.

    Thanx for your help.

     
  • Mariano Absatz

    Mariano Absatz - 2012-10-13
    • status: open --> open-invalid
     
  • sabitov

    sabitov - 2012-10-23

    Sorry for that, but what exactly should be changed?

     
  • Christian Boltz

    Christian Boltz - 2013-03-24
    • status: open-invalid --> closed-fixed
     
  • Christian Boltz

    Christian Boltz - 2013-03-24

    This was a regression caused by the security fixes in 2.3.5 and should be fixed in PostfixAdmin 2.3.6.

    If you still see this problem with 2.3.6, please reopen ;-)

     

Log in to post a comment.