omfgppc - 2008-09-15

pclark wrote: Hi,

Try installing libssl and libcrypto.  They''ll be installed under /usr/lib and they will be called libcrypto.so.X.X and libssl.so.X.X (they may or may not have values for X).

You may need to install the devel packages for these also.

All you need to do is to create symbolic links from libcrypto and libssl to libcrypto.so.4 and libssl.so.4.

For your Windows issue, I''m assuming that linux is the postgresql server and windows is the client.  You need to modify the postgresql.conf and pg_hba.conf file in the /data directory. 

Set the parameters

FROM:
[code:1:e791e8217e]listen_addresses = ''localhost''         # what IP address(es) to listen on;[/code:1:e791e8217e]

TO:
[code:1:e791e8217e]listen_addresses = ''*''          # what IP address(es) to listen on;[/code:1:e791e8217e]

And save the file.

Open up the pg_hba.conf file and check you settings. 
[color=red:e791e8217e][b:e791e8217e]DO NOT USE THESE SETTINGS IN PRODUCTION! FOR TESTING ONLY[/b:e791e8217e][/color:e791e8217e]
This will allow you to connect from anywhere without a password.
[code:1:e791e8217e]# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

# \"local\" is for Unix domain socket connections only
local   all         all                               trust
# IPv4 local connections:
host    all         all         127.0.0.1/32          trust
host    all         all        192.168.0.0 0.0.0.0 trust
# IPv6 local connections:
host    all         all         ::1/128               trust
[/code:1:e791e8217e]
And save the file.

Restart PostgreSQL and try to log in from the Windows box. -- Read more at http://www.xtuple.org/phpBB2/viewtopic.php?t=2790