Linux installation

Mark Vojta
  • Mark Vojta

    Mark Vojta - 2010-05-02

    I have downloaded the file xTuple-3.4.0-linux-installer.bin to my desktop.  When I douple click on the icon it says ther is no application for this file type.  I could not find any installation instructions on the website.  I am running Ubuntu 8.04.  Can you provide any assistance?

  • Chris Ryan

    Chris Ryan - 2010-05-05

    Ubuntu, for reasons unknown to myself, does not like to run the installer from the desktop when you click on it. You will have better success if you run it from a command line. In addition, if you are not running as the administrator, you will need to sun the installer under sudo. Running it under sudo gives the installer the appropriate permissions it needs to correct configure some of the components. Your basic steps would be something like this:

    open command line
    cd to the Desktop or where ever you have stored the installer file
    run the following command: sudo ./xTuple-3.4.0-linux-installer.bin
    enter your password if requested (this is sudo asking for the password not xTuple)
    installer should run correctly

  • Mark Vojta

    Mark Vojta - 2010-05-07

    I tried what you recommended and got the response "command not found".  I also tried the full pathname and got the same result.  At this point I wonder if I should check with Ubuntu support.  It seems that they should be able to recognize .bin files.

  • Mark Vojta

    Mark Vojta - 2010-05-07

    I guess not all downloaded files that are executables are flagged that way. Probably a security feature.  I needed to use the command :
        chmod +x xTuple-3.4.0-linux-installer.bin
    The rest of the install seemed to go smoothly. Thanks.


Log in to post a comment.