Impossible to read rss from https

Help
Nezetm
2012-01-06
2013-05-20
  • Nezetm

    Nezetm - 2012-01-06

    Hello,

    the feeds coming from an https application doesn't work, the answer is : "The RSS flux seems not valide or not available". I tested from intranet and Internet. Is there something to do in Posh ?
    Example of feed : ie. https://www.widexs.nl/xml/nieuws.xml
    It works with Netvibes.

    Happy new year to Posh users !

     
  • Eric Mathieu

    Eric Mathieu - 2012-01-06

    Hello Michael,

    Happy new year !

    You need to activate the PHP ssl extension to read https feeds. On my server, I activated the php_openssl extension to have the https feeds worked.

    Cheers

     
  • Nezetm

    Nezetm - 2012-01-09

    Bonjour Eric,

    I activated php_openssl, restarted the server, it doesn't work yet. Here after the activated extensions, perhaps i missed something ? I continue to investigate.

    ;extension=php_bz2.dll
    ;extension=php_curl.dll
    ;extension=php_dba.dll
    ;extension=php_exif.dll
    ;extension=php_fileinfo.dll
    extension=php_gd2.dll
    ;extension=php_gettext.dll
    ;extension=php_gmp.dll
    ;extension=php_intl.dll
    ;extension=php_imap.dll
    ;extension=php_interbase.dll
    ;extension=php_ldap.dll
    extension=php_mbstring.dll
    ;extension=php_ming.dll
    ;extension=php_mssql.dll
    extension=php_mysql.dll
    extension=php_mysqli.dll
    ;extension=php_oci8.dll     
    ;extension=php_oci8_11g.dll
    extension=php_openssl.dll
    ;extension=php_pdo_firebird.dll
    ;extension=php_pdo_mssql.dll
    extension=php_pdo_mysql.dll
    ;extension=php_pdo_oci.dll
    ;extension=php_pdo_odbc.dll
    ;extension=php_pdo_pgsql.dll
    extension=php_pdo_sqlite.dll
    ;extension=php_pgsql.dll
    ;extension=php_phar.dll
    ;extension=php_pspell.dll
    ;extension=php_shmop.dll
    ;extension=php_snmp.dll
    ;extension=php_soap.dll
    ;extension=php_sockets.dll
    ;extension=php_sqlite.dll
    ;extension=php_sqlite3.dll
    ;extension=php_sybase_ct.dll
    ;extension=php_tidy.dll
    ;extension=php_xmlrpc.dll
    ;extension=php_xsl.dll
    ;extension=php_zip.dll

     
  • Nezetm

    Nezetm - 2012-01-12

    I found nothing and this is a blocking point.
    Posh is behind a proxy but http flux is ok and https is correctly read on my IE or Firefox.  Posh Is installed on a recent Wamp server.
    If someone can suggest.
    Cheers

     
  • Eric Mathieu

    Eric Mathieu - 2012-01-12

    Hi Michael,

    Could you modify /includes/http.inc.php file by replacing :

    $socket = @fsockopen($this->protocol.$this->server,$this->port,$errNo,$errStr,$this->timeout);
    if (!$socket) $socket = @fsockopen($this->server,$this->port,$errNo,$errStr,$this->timeout);
    

    by

    $socket = fsockopen($this->protocol.$this->server,$this->port,$errNo,$errStr,$this->timeout);
    if (!$socket) $socket = fsockopen($this->server,$this->port,$errNo,$errStr,$this->timeout);
    

    And give us the response of the xmlvalidrss.php script using firebug (page called when you add the RSS feed url in Posh). It should contain an error message that will help to solve your issue.

    Cheers

     
  • Nezetm

    Nezetm - 2012-01-12

    I don't know if am doing right with firebug….here after the results of the "console". No error message…

    http://obedprojetplm/sentinel/portal/xmlvalidrss.php?url=https%3A%2F%2Frss.microsoftonline.com%2Ffeeds.aspx%3Fcenter%3Ddefault%26chan%3Dnotifications%26lang%3Den-us&useproxy=1 200 OK  200ms 200 OK

    Réponse (502) :

    Connection Keep-Alive
    Content-Length 6
    Content-Type text/html; charset=UTF-8
    Date Thu, 12 Jan 2012 15:20:15 GMT
    Keep-Alive timeout=5, max=100
    Server Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/0.9.8r PHP/5.3.8
    X-Powered-By PHP/5.3.8
    Requête
    Accept text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Charset ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Accept-Encoding gzip, deflate
    Accept-Language fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
    Connection keep-alive
    Content-Length 122
    Content-Type application/x-www-form-urlencoded; charset=UTF-8
    Cookie myhomepage=ll5b6kism566evktohg2k1j590; encrypt_key=3097873454f0ef71b0e1b1; nbconn=44; currentpage=1; showmenu=1; hidemessage=Sentinel : monitor the web !; laststate=$p.app.pages.change(1); admlaststate=$p.app.tabs.open(8); myhomepage=ll5b6kism566evktohg2k1j590
    Host obedprojetplm
    Referer http://obedprojetplm/sentinel/portal/mypage.php
    User-Agent Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

     
  • Nezetm

    Nezetm - 2012-01-18

    Hello,
    i solved the problem by removing https from the server wich delivered the rss feeds. Now it works with the http flux.
    Cheers

     
  • Eric Mathieu

    Eric Mathieu - 2012-01-18

    Hello Michael,

    Nice to hear that you solved your issue. I looked at the data you sent me but this did not help me to understand the problem. I guess this is a SSL issue on your server.

    Cheers,

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks