#17 Doesn't work with Netbeans defalut keystore

open-works-for-me
nobody
None
5
2012-08-26
2012-08-18
No

Looks like a dead project. Bugs untouched for 7 years.

Well just in case:
portecle-1.7, Netbeans 7.2
I can open the Netbeans default keystore using
keytool -list -keystore ...builtin.ks
with a blank password, and it shows three certificates.

Portecle in contrast, shows a blank screen, no error message, on stderr or otherwise.
Just nothing.

Discussion

  • Ville Skyttä

    Ville Skyttä - 2012-08-25
    • status: open --> closed-works-for-me
     
  • Ville Skyttä

    Ville Skyttä - 2012-08-25

    Looks like a bug report with weird, unrelated, hastily drawn conclusions apparently based on incomplete home work in the beginning.

    Well, just in case:

    There's no "builtin.ks" keystore file in the netbeans 7.2 I just downloaded. There is however a ide.ks in the nb/core subdir, and that one opens successfully with Portecle using the password "open4all" for me. Note that unlike keytool, Portecle doesn't support opening keystores in "read only mode", ie. without a password.

    If you have the keystore file that can be used to reproduce the "blank screen" problem, feel free to reopen this bug and attach or email it along with its password.

     
  • Stevan White

    Stevan White - 2012-08-26

    Pardon the hastiness. I was frustrated.

    I should have added: the keystore in question is in
    ~/.netbens/config/j2me/builtin.ks
    It didn't occur to me at the time that it was j2me-specific.

    This may be added when J2ME project is created (it isn't clear to me; I only know I didn't do anything special.)
    As I think the contents are auto-generated, I'll attach it ... I *would* attach it. I don't see how, at this point. There seems to be no option to do that.

    As to support for blank passwords,
    This is stil a UI bug. It should give the user some indication of what went wrong, or what to do next.

     
  • Stevan White

    Stevan White - 2012-08-26

    scop,

    I looked into the attachment issue.

    The reason I don't see any means to attach a file, is probably that the report is closed.

    It seems the capacity of a submitter to re-open a ticket was removed some time ago.

    If you would like to see the example file, please re-open the report.

     
  • Ville Skyttä

    Ville Skyttä - 2012-08-26

    Under no circumstances should the "just blank" behavior occur. The bug is now open again, try attaching again now.

     
  • Ville Skyttä

    Ville Skyttä - 2012-08-26
    • status: closed-works-for-me --> open-works-for-me
     
  • Stevan White

    Stevan White - 2012-08-26

    From .netbeans/7.2/config/j2me/

     

Log in to post a comment.