install PopFile on RH EL4 - what a mess!!

HOWTO
2007-12-26
2013-04-15
  • Willem van Schaik

    I have been using PopFile from the early, early days, however always on Windows. Installing and configuring has never costed me more than 10 minutes.

    Today I decided to put it on a new desktop running Linux (in this case RH EL4, but I don't think that the distro really matters) and was I in for some surprises!! At first I saw that the current version is now 1.0, which after using the system for years seems absolutely correct, but based on my experiences after that, I guess 0.8 would be a better choice.

    OK, where does it go wrong. First of all unzipping a package and then still having to use 'chmod' on various files is weird. And for a Linux package, .tar.gz is probably the better choice. Further, the package doesn't contain a README or INSTALL file. Mmmm, that's not a good sign.

    I found the install scripts for RedHat and followed those. Didn't help much if "perl /usr/popfile/popfile.pl" isn't yet working properly.

    Then I tried to follow the instructions for the 'cross platform version', I had to setup CPAN (guess some people will fail already halfway that part, but it went OK for me) and then things went really wrong with installing the various Perl modules. DBI was still OK, but then DBD::SQLite failed (although when I do "perl -MDBD::SQLite -e 'print $DBD::SQLite::VERSION'" it returns with version 1.14) also DBD::SQLite2 fails with "DIED. FAILED tests 12-49 Failed 38/49 tests, 22.45% okay" which doesn't look good either.

    Trying to "install M/MS/MSERGEANT/DBD-SQLite-0.31.tar.gz" doesn't make any difference. Then tried the DBD::mysql module, failed just as miserable. Let's try PostgreSql, I have that also installed, but then http://popfile.sourceforge.net/wiki/postgresqlbackend isn't really a recommendation to go forward that route.

    OK, so the result is pretty much a deadlock.

    After creating the wrapper scripts in /sbin and also setting the two environment variables, the program starts, but quickly thereafter complains about:

    install_driver(SQLite2) failed: Can't locate DBD/SQLite2.pm in @INC (@INC contains: /usr/popfile/ /usr/lib/perl5/5.8.5/i386-linux-t.......

    Which makes sense of course, but how to fix it? Ahhh, I find it!! :-) The INSTALL instruction page has a weblink stating "There is a detailed explanation of the SQLite2 and SQLite3 issue here", which points to "http://popfile.sourceforge.net/wiki/howtos:sqlite3", which then says "You’ve followed a link to a topic that doesn’t exist yet. If permissions allow, you may create it by using the Create this page button.".

    So, I will have to write my own help..... :-)

    OK, all ranting aside, PopFile is great piece of software. I like it so much that long time ago I even donated  some hard dollars to the project. But today's experience is really not version 1.0 quality. And I'm not using a wierd Linux distro. I think RH EL 4AS is pretty mainstream. Maybe the decision to step away from the BerkelyDB was the wrong one. I don't know.....

     
    • Willem van Schaik

      OK, I got it figured out. I finally installed the SQLite package with:

       
    • Willem van Schaik

      OK, I got it figured out. I finally installed the SQLite package with:

          force install DBD::SQLite2

      And after that, popfile.pl was able to start. I put the SuSE start/stop script in my RedHat /etc/init.d and that worked fine (of course I also did a "chkconfig --add popfile").

      One more tip, if you do this install on a system that never did any CPAN updates, you have to install first the ncftp package (I downloaded mine from rpm.pbone.net), because the perl updates are using ncftpget. But you will be told about that only "late in the game".

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks