make.exe

joshua
2005-06-22
2013-04-15
  • joshua

    joshua - 2005-06-22

    D:\cvsroot\engine>make -C D:\cvsroot\engine windows
    make.exe: Entering directory `d:/cvsroot/engine'
    perlapp --gui --exe popfile.exe --force --clean --dependent --xclude --icon ../w
    indows/POPFileIcon/popfile.ico --icon trayicon.ico --script popfile-windows.pl -
    -info CompanyName="The POPFile Project" --info LegalCopyright="Copyright (c) 200
    3 John Graham-Cumming" --info ProductName=POPFile --info ProductVersion=0.22.2.0
    --info FileDescription=POPFile --info FileVersion=0.22.2.0
    make.exe: *** [popfile.exe] Error -1
    make.exe: Leaving directory `d:/cvsroot/engine'

    am i missing something???

     
    • Brian Smith

      Brian Smith - 2005-06-22

      Have you installed ActiveState's Perl Dev Kit (PDK)?

      The PDK is used to build the following files:

      popfile.exe
      popfileb.exe
      popfilef.exe
      popfileib.exe
      popfileif.exe
      popfile-service.exe

      Brian

       
    • joshua

      joshua - 2005-06-22

      563 tests, 325 ok, 238 failed

      make.exe[1]: *** [runtest] Error 1
      make.exe: *** [test] Error 2

      i got the pdk but still get the
      make.exe: *** [popfile.exe] Error -1

       
      • Texas Fett

        Texas Fett - 2005-06-22

        If you checked out the head from CVS the tests aren't done yet since that code is still in development and it doesn't completely work.

        If you are getting the tag for 0.22.2 then those tests should all work (I think), but some of the official developers can't get all the tests for 0.22.x to run either.  I don't think we know why though.

        I was looking through old messages for an answer and came across one that said to use the command:

          make eachtest

        I have never tried running the tests myself but hopefully that gets everything to work.

         
    • joshua

      joshua - 2005-06-22

      D:\cvsroot\engine>make eachtest
      Running test suite
      Command line too long.
      make.exe[1]: *** [eachtest] Error -1
      make.exe: *** [eachtest] Error 2

      hehehe

       
    • John Graham-Cumming

      The test suite that's in CVS is broken right now.  I wouldn't attempt to run the tests.

      John.

       
    • joshua

      joshua - 2005-06-22

      D:\cvsroot\engine>popfileif.exe
      Can't locate object method "debug" via package "POPFile::Loader" at popfile-tray
      .pl line 137.

      getting closer

       
    • joshua

      joshua - 2005-06-22

      the icons are messed up and my exe dont have nice little sea creatures

       
      • Brian Smith

        Brian Smith - 2005-06-23

        >> the icons are messed up and my exe dont have nice little sea creatures <<

        Although the Perl source code files for the popfile*.exe files and the system tray icon file are in the 'engine' directory, the icon file for the popfile*.exe files is stored in a separate directory (../windows/POPFileIcon).

        You can see this clearly in the following extract from the message which started this topic:

        "--icon ../windows/POPFileIcon/popfile.ico --icon trayicon.ico"

        When you used CVS to get the files required to rebuild POPFile did you also get the 'popfile.ico' file ?

        Brian

         
    • joshua

      joshua - 2005-07-13

      yeap i got that dir and the dont seem to be valid files

       
      • Brian Smith

        Brian Smith - 2005-07-13

        >> yeap i got that dir and the dont seem to be valid files <<

        If you were replying to my message (about "--icon ../windows/POPFileIcon/popfile.ico --icon trayicon.ico") try getting the two icon files from CVS again.

        You can either use your CVS software to get the files again or you can use SourceForge's "CVS Browser" (see the "CVS" link at the top of this page).

        Here are some download links I found using the CVS Browser:

        http://cvs.sourceforge.net/viewcvs.py/\*checkout*/popfile/windows/POPFileIcon/popfile.ico?rev=1.6

        http://cvs.sourceforge.net/viewcvs.py/\*checkout*/popfile/engine/trayicon.ico?rev=1.3

        Both links downloaded files that look OK to me (popfile.ico was 26,582 bytes and trayicon.ico was 3,438 bytes).

        Brian

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks