BeOS don't compile

2000-08-22
2000-08-23
  • Gianpaolo Mazzoni

    Hi, I've a problem to compile the 1.0 version with the BeOS 5.
    This is the output from the Terminal after the command make (I uncommented the line in makefile):

    /boot/home/Temporanea/pnm2ppa-1.0 #make
    gcc -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -c pnm2ppa.c
    /boot/home/Temporanea/pnm2ppa-1.0/pnm2ppa.c: In function `print_pnm':
    /boot/home/Temporanea/pnm2ppa-1.0/pnm2ppa.c:63: warning: int format, long int arg (arg 2)
    gcc -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -c ppa.c
    /boot/home/Temporanea/pnm2ppa-1.0/ppa.c:450: warning: ANSI does not permit the keyword `inline'
    /boot/home/Temporanea/pnm2ppa-1.0/ppa.c:457: warning: ANSI does not permit the keyword `inline'
    gcc -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -c image.c
    /boot/home/Temporanea/pnm2ppa-1.0/image.c: In function `remallocBuffer':
    /boot/home/Temporanea/pnm2ppa-1.0/image.c:251: warning: int format, long int arg (arg 3)
    gcc -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -c dither.c
    gcc -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -c cutswath.c
    gcc -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -o make_hash_ink make_hash_ink.c
    /boot/home/Temporanea/pnm2ppa-1.0/make_hash_ink.c:50: warning: ANSI does not permit the keyword `inline'
    ./make_hash_ink 4 3 > hash_ink.c
    ./make_hash_ink 1 5 >> hash_ink.c
    gcc -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -c hash_ink.c
    gcc -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -c syslog.c
    gcc -lm -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -o pnm2ppa pnm2ppa.o ppa.o image.o dither.o cutswath.o hash_ink.o syslog.o
    /boot/develop/tools/gnupro/bin/ld: cannot open -lm: No such file or directory
    collect2: ld returned 1 exit status
    make: *** [pnm2ppa] Error 1

    Thanks in advance for the help.

    Gianpaolo

     
    • Anonymous - 2000-08-22

      well your compile step worked, but the loader  (ld) seems to
      have misinterpreted  LDFLAGS=-lm
      as a file. 

      pnm2ppa-1.0 wasnt tested on BeOS, but if you search the mailing
      list archives  (either ppa.devel or ppa.users)
      someone was talking about BeOS, and got pnm2ppa  working on BeOS.
      look  on the project homepage.

      If the makefile for BeOS needs some  syntax changes, please send a
      message to ppa.devel giving us the correction.

      Try identifying BeOS pnm2ppa users and  ask them for help.

      good luck.

       
    • Anonymous - 2000-08-22

      gcc -lm -Wall -pedantic -O2 -g -DNDEBUG -D__BEOS__ -DLANG_EN -o pnm2ppa pnm2ppa.o ppa.o image.o dither.o cutswath.o   hash_ink.o syslog.o

      actually, you seem to have successfully built  the pnm2ppa  executable binary,

       
      • Anonymous - 2000-08-22

        well maybe not,  did this step fail because of the -lm flag to gcc?

         
    • Anonymous - 2000-08-23

      OK,

      leave the
      #LDFLAGS=-lm
      commented out for the BeOS build.

      see the posts in ppa.users:

      PPA Users Discussion Home Page: Archive: Message #581

                          Date:
                                            Jun 14 2000 18:36:23 EDT
                          From:
                                            Ryan Shannon <rshannon@wcug.wwu.edu>
                          Subject:
                                            BeOS woes

      Hola. I'm trying to get pnm2ppa working on my beos R5 install with an HP 722C.
      I downloaded the .99pre3 tarball, unzipped her and commented out the production
      build section - uncommenting the beos production build section minus the lm
      flag line.  make works fine and I put pnm2ppa and calibrate in /boot/home/config/bin.  I then made a script that reads

      <snip> (his first script failed)
      then

                          PPA Users Discussion Home Page: Archive: Message #598

                          Date:
                                            Jun 21 2000 00:29:58 EDT
                          From:
                                            Ryan Shannon <rshannon@wcug.wwu.edu>
                          Subject:
                                            No more BeOS woes :)

      Yeah, baby! :)  That mother prints!  Here's what I did:

      made a script called pnm

      #! /bin/sh
      pnm2ppa -i - -o /dev/parallel/parallel1

      and then I made my printps script as follows

      #!/bin/sh
      cat $1 |  gs -sDEVICE=ppmraw -q -dNOPAUSE -r600 -sOutputFile=\|pnm -

      The neatto trick here is the -sOutputFile=\|pnm voodoo.  For whatever reason,
      it likes that mo better.  Thanks for everyone's help.

                           Ryan

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks