#42 pngcrush: Compilation with libpng 1.5 fails

None
closed
devel (22)
5
2013-05-01
2011-10-08
Hanno Böck
No

I know you're aware of that, but I wanted to have this bug open to track progress.

What's the status of libpng 1.5 support? I'm currently struggling to keep pngcrush in Gentoo and things would be much easier if pngcrush would work with libpng 1.5.

Discussion

  • Glenn Randers-Pehrson

    For now use the full version (with the bundled libpng-1.5 and zlib), not the "nolib" version. It uses libpng private functions and therefore won't work with a DLL or shared library.

     
  • Glenn Randers-Pehrson

    As of version 1.7.57, pngcrush can be built with libpng-1.5.x or 1.6.x.

     
  • Glenn Randers-Pehrson

    • status: open --> closed
    • assigned_to: Glenn Randers-Pehrson
    • Group: -->
     
  • Glenn Randers-Pehrson

    Pngcrush version 1.7.58 works with libpng15 and 16.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks