Unable to compile Plume Creator

Anonymous
2013-07-23
2013-07-24
  • Anonymous - 2013-07-23

    I'm attempting to compile Plume Creator from source. Platform is Gentoo 64-bit Linux with QT 4.8. Here's the link to the terminal output: http://pastebin.com/9qxeSJnC

    I'm not at all familiar with compiling qt programs, though I have successfully compiled krita from git. So probably it's a case of user error.

    Thanks! for any assistance in getting Plume Creator to compile.

     
  • Elle Stone

    Elle Stone - 2013-07-24

    This is mostly a test post. I don't know why my first post is listed as being by "Anonymous" as I was (and also currently am) signed in to Sourceforge as myself.

    I did manage to install Plume Creator and if this test post appears, I'll explain the modifications I made to the main.cpp file to get it to install.

     
  • Elle Stone

    Elle Stone - 2013-07-24

    The reason Plume Creator from git wouldn't install on my 64-bit Gentoo Linux OS is because I don't have any desktop environment. I use Icewm instead. On Gentoo, if you want to run a KDE program, you can get by with a lot fewer KDE dependencies than on most other Linuxes.

    I do run quite a few QT programs and I do have two KDE programs installed (digiKam and calligra-krita, krita being installed from git). But I don't have the KDE desktop installed. I also run quite a few GTK apps, but don't have any Gnome desktop programs installed.

    So to get Plume Creator to install, I opened up main.cpp and commented out the following sections:

    /* elle: never mind the desktop - I don't have one.

    ifdef Q_OS_LINUX

    else if(plumeStyle == "gtk" ){
        QApplication::setStyle(new QGtkStyle);
        QApplication::setStyle(new QCleanlooksStyle);
    }
    

    endif

    ifdef Q_OS_WIN32

    else if(plumeStyle == "vista" ){
        QApplication::setStyle(new QWindowsVistaStyle);
    }
    else if(plumeStyle == "xp" ){
        QApplication::setStyle(new QWindowsXPStyle);
    }
    

    endif

    ifdef Q_OS_MAC

    else if (plumeStyle == "osx" ){
        QApplication::setStyle(new QMacStyle);
    }
    

    endif */

    else if (plumeStyle == "default" ){
    
        QApplication::setStyle(new QPlastiqueStyle);
    

    /*

    ifdef Q_OS_LINUX

        // Checking the current Desktop Environment on Linux :
    
        QString program = "/bin/pidof";
        QStringList arguments;
        arguments << "ksmserver";
        QProcess *myProcess = new QProcess();
        myProcess->start(program, arguments);
        myProcess->waitForFinished();
        if(myProcess->readAllStandardOutput().size() > 0){
            QApplication::setStyle(new QPlastiqueStyle);
            qDebug() << "Running on KDE";
        }
        myProcess->close();
        arguments.clear();
        arguments << "gnome-session";
        myProcess->start(program, arguments);
        myProcess->waitForFinished();
        if(myProcess->readAllStandardOutput().size() > 0){
            QApplication::setStyle(new QGtkStyle);
            QApplication::setStyle(new QCleanlooksStyle);
            qDebug() << "Running on Gnome";
        }
        myProcess->close();
        arguments.clear();
        arguments << "xfce-mcs-manage";
        myProcess->start(program, arguments);
        myProcess->waitForFinished();
        if(myProcess->readAllStandardOutput().size() > 0){
            QApplication::setStyle(new QGtkStyle);
            qDebug() << "Running on XFCE";
        }
        myProcess->close();
        //    if [ "$(pidof ksmserver)" ]; then
        //       echo "KDE running."
        //       # KDE-specific stuff here
        //    elif [ "$(pidof gnome-session)" ]; then
        //       echo "GNOME running."
        //       # GNOME-specific stuff here
        //    elif [ "$(pidof xfce-mcs-manage)" ]; then
        //       echo "Xfce running."
        //       # Xfce-specific stuff here
        //    fi
    

    endif

    */

    I also modified the plume-creator.pro file thusly:

    unix: !macx {
    isEmpty(PREFIX) {
    PREFIX = /usr/local
    }

    So it installed in /usr/local instead of /usr. And Plume Creator runs. I do have some questions and suggestions, but will post them separately.

    Elle Stone

     
  • Cyril Jacquet

    Cyril Jacquet - 2013-07-24

    Hello Elle,

    I understand you don't have a desktop, but these sections you commented are used to apply graphical styles. It's a mimic. On Linux, only GtkStyle needs Gnome to work.
    Maybe Plume thinks falsely you are running gnome. Have you "Running on Gnome" displayed if you run the original Plume in a terminal ? If so, try to compilecommenting only the part "QApplication::setStyle(new QGtkStyle);".

    Thank you for your interest .

    Regards,
    Cyril

     
  • Anonymous - 2013-07-24

    Hi Cyril,

    What does "It's a mimic" mean?

    Running plume-creator in a terminal, here's the output:

    $ ./plume-creator
    project added
    project added

    JOB ##########

    job : "extract"
    file : "/home/elle/plume/plumetest.plume"
    post path : "/tmp/Plume/plumetest"
    path : "/tmp/Plume/plumetest"

    I do have gnome-base/gnome-common, gnome-base/libglade, and gnome-base/libsvg installed on my computer, but those are the only "gnome-base" programs that are installed.

    Is there a reason to recompile plume-creator to add in the additional graphical styles? Is any new functionality thereby included, that isn't included the way I compiled plume-creator, with the whole section commented out?

    I did recompile after modifying main.cpp to comment out three lines that refer to QApplication::setStyle(new QGtkStyle); and plume-creator still runs, still doesn't detect any gnome desktop, same output from the terminal as above.

     
  • Anonymous - 2013-07-24

    Why are my posts being posted as by "Anonymous"? I'm signed in to sourceforge! Is there some extra step I need to take?

     
  • Cyril Jacquet

    Cyril Jacquet - 2013-07-24

    QApplication::setStyle() applies the wanted style (paintings) to the application. In your case, Plume doesn't detect any desktop, it keeps the default style, Cleanlooks. I plan to remove the Gtand Windows looks since I am setting a personalized style (colors, button size, ...).

    I modified the logged users settings. Now you can create messages.

     
  • Cyril Jacquet

    Cyril Jacquet - 2013-07-24

    It is only a guess, but seeing your pastebin, I think you need gtk development dependencies to compile Plume successfully.

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks