Bug Reports

2012-01-08
2015-12-29
1 2 > >> (Page 1 of 2)
  • Anonymous - 2012-06-10

    Hi, trying to build the current git version under Arch Linux (GCC 4.7.0, Qt 4.8.2) fails with the following error:

    [andre@archbook plume-creator-code]$ LANG=en_EN.utf8 make
    g++ -c -m64 -pipe -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt/mkspecs/linux-g++-64 -I. -I/usr/include/QtCore -I/usr/include/QtNetwork -I/usr/include/QtGui -I/usr/include/QtXml -I/usr/include -Iexternals/qtsingleapplication/src -I. -o qtlocalpeer.o externals/qtsingleapplication/src/qtlocalpeer.cpp
    externals/qtsingleapplication/src/qtlocalpeer.cpp: In constructor 'QtLocalPeer::QtLocalPeer(QObject*, const QString&)':
    externals/qtsingleapplication/src/qtlocalpeer.cpp:103:54: error: '::getuid' has not been declared
    externals/qtsingleapplication/src/qtlocalpeer.cpp:103:54: note: suggested alternative:
    In file included from externals/qtsingleapplication/src/qtlockedfile_unix.cpp:49:0,
                     from externals/qtsingleapplication/src/qtlocalpeer.cpp:67:
    /usr/include/unistd.h:698:16: note:   'QtLP_Private::getuid'
    make: *** [qtlocalpeer.o] Error 1
    
     
    • Cyril Jacquet

      Cyril Jacquet - 2012-06-10

      Hi "Anonymous",
      Thank you very much for the report. As I don't run Arch Linux (amd64 I guess), I couldn't have found this bug.
      This bug comes from the sub-program "qtsingleapplication" which forbid multiple instances of Plume. It's a known bug because I am not the only person using this little program.
      Maybe I found an answer here : https://aur.archlinux.org/packages.php?ID=56574

      I modified my source for you to test it. See the attachment.
      Can you compile it and report afterward ? Thanks.

      regards,
      Cyril Jacquet

       
  • Anonymous - 2012-06-11

    Hello Cyril,

    it compiles now cleanly, thanks!

    regards,
    Andre

     
  • dodmo

    dodmo - 2012-06-16

    Hi.
    Have just installed the ,deb package on Ubuntu 10.04 clicked the icon in the menu and nothing happened, tried to start it in terminal got the following error message:

    plume-creator: symbol lookup error: plume-creator: undefined symbol: _ZN9QListData11detach_growEPii
    

    regards
    dodmo

     
    • Cyril Jacquet

      Cyril Jacquet - 2012-06-20

      Hi dodmo,
      I will see into that tonight. Do you run Ubuntu 32 bit or 64 bit ? Maybe you can upgrade your system to Ubuntu 11.4 LTS ? Your Qt libraries can be outdated.

      Regards,
      Cyril Jacquet

       
  • dodmo

    dodmo - 2012-06-22

    It's 32 bit.
    Not keen to upgrade a working LTS version with all the possible problems that entails.

    Don't go to any bother on my behalf, I only reported the problem for your info.

    Thanks
    dodmo

     
  • PhaserRave

    PhaserRave - 2012-09-17

    Hello. First, I'd just like to say how much I like the idea of this program. It's really great, and thank you for programming it.

    I'm running on a 64-bit win 7 system, and I've found a bit of lag and crash that I can't seem to duplicate. I ran in to the lag in the Attendance Manager, right after I tried clicking on the Last Name field as I was in the process of adding a new character. It froze for a moment. After that, I had added a new place, clicked to close the Manager, and the program crashed.

     
    • Cyril Jacquet

      Cyril Jacquet - 2012-09-17

      Hello Phaser,

      Thank you to report this bug. Sadly, I am not able to reproduce it.
      A new Attendance manager will come soon, with a brand new code, so the bug will disappear.

      I hope you have not lost data with this crash.

      Cordialement,
      Cyril Jacquet

       
  • Anonymous - 2012-09-22

    Hello.
    First of all, I want to thank Cyril for his work with this software.

    I have the same problem of dodmo: ubuntu 10.04, 32 bit -- and plume creator doesn't start when you click on the menu. A quick image of the logo just appears for a second, and then nothing.

    I would like to use your software, but I can't switch to another version of ubuntu: my computer is not up-to-date, and it works well with 10.04, but it's too slow with others. Besides, I feel comfortable with it.

    If you can help us, it would be great, but I figure you have a lot of work to do.

    Regards.

     
  • Cyril Jacquet

    Cyril Jacquet - 2012-09-24

    Hello !
    Sorry for replying so late.
    I don't have ubuntu 10.04. Have you enabled the "backport" repository ? Maybe a more up-to-date version of Qt libraries is here.
    Check the sources of your package manager. (mine is Synaptics)

    If you don't know how to do that, there are nice tutorials in the ubuntu wiki.

    I hope this helps !

    Cordialement,
    Cyril Jacquet

     
    • Anonymous - 2012-09-24

      Thank you for replying.

      I'm not very expert in computer's matters (and in English, as you can see -- sorry for that). I tried to follow your advice -- I enabled "backport" repository, I looked around on the web... but I couldn't find a solution.
      My libqt4-core version is 4.6.2. Plume-creator needs at least 4.8.1 version. It seems that ubuntu lucid (10.04) can't use it (though I was able to understand -- I repeat, I'm not expert).

      It's a shame, because I would really like to try the software.

      I understand that you can't wasting time for solving a problem concerning an old operating system. Someday, I'll buy a more performing machine.

      Thank you for your work,
      Vitige

      PS: Maybe, someone more experienced than me who solved the problem can share his/her solution with us.

       
      • Cyril Jacquet

        Cyril Jacquet - 2012-09-24

        Sorry to have no answer to your problem.

        Before buying a new machine, I suggest you try the lastest Ubuntu "live" with an USB key, maybe it's working fine. Personnaly, I'm using Mint Cinnamon, a lighter interface. There is also Xubuntu or Lubuntu for older hardware. I can run Ubuntu 12.4 in a poor 1ghz processor.
        You can install Plume in these OS in a live session. Just for trying purpose.

        Good luck !

         
  • Anonymous - 2012-10-15

    Running Linux Mint 13 64bit Cinnamon - error with deb package install, shows up on menu under office - yet won't run. Reinstalled package - no error indicated, yet still won't run.

     
    Last edit: Cyril Jacquet 2012-10-16
  • Anonymous - 2012-10-20

    Running Plume Creator on a Linux Mint 32-bit machine, it doesn't save anything I write in fullscreen-mode. Which was basically the reason I like the program.

    I wrote almost 800 words and hit strg+s several times. When I exited the fullscreen-mode, everything was gone. Same for the changes I made to another document.

    I would really love to continue using this program. But that bug makes it unusable.

     
    • Cyril Jacquet

      Cyril Jacquet - 2012-10-29

      Hi,
      It's strange. You don't need ctrl-s as Plume save all automaticaly, but the Fullscreen mode isn't finished. It's content is copied back in the opened sheet only when you type Escape key or click on the exit button.

      Does this bug always appear ?

      Regards

       
      • Anonymous - 2012-11-02

        Yes, it always happens. It doesn't even appear in the opened sheet. It's as if I never wrote it. I tried the escape key and the exit button - same result, sadly.
        Has there been a problem with Plume on Linux Mint 11? Because I haven't updatet the system yet.

        I'm gonna try a new install today, so we'll see. I really love the layout of Plume though and hope it's going to work.

         
      • Anonymous - 2012-11-03

        I tried a new install on my machine and another on a fresh Linux Mint 13 one - same bug. I have no idea why, but everything written in fullscreen mode disappears.

         
        • Cyril Jacquet

          Cyril Jacquet - 2012-11-03

          Hi, I found the bug. I'm trying to fix it now.
          Thanks to have reported it !

           
          • Cyril Jacquet

            Cyril Jacquet - 2012-11-03

            Meanwhile, if you don't want to lose your text, modify the zoom.

             
          • Anonymous - 2012-11-05

            Thank you. Can't wait to work with it in the full screen. It's such a smart program.

             
            • Cyril Jacquet

              Cyril Jacquet - 2012-11-30

              I released Plume v0.55, which fix this fullscreen problem

               
  • Anonymous - 2012-10-28

    Seems to install OK but will not run on Ubuntu 12.04. I get this message:

    plume-creator: error while loading shared libraries: libQtXml.so.4: cannot open shared object file: No such file or directory

    I could not find a package by that name in the repository. Shouldn't the deb file take care of installing any dependencies?

     
    • Cyril Jacquet

      Cyril Jacquet - 2012-10-29

      I have not a 32 bit system yet, so I can't test it right now.
      Type in a terminal :
      sudo apt-get install ia32-libs

      and / or

      sudo apt-get install --reinstall libqt4-core
      sudo apt-get install --reinstall libqt4-xml

      Please tell me if it's working ! Thanks

      Regards,
      Cyril

       
      • Anonymous - 2012-10-31

        I am actually on 64 bit Ubuntu 12.04. After reinstalling those 2 pkgs (libqt4-core and libqt-xml) I still get the same error message, that it can't find libQtXml.so.4

         
1 2 > >> (Page 1 of 2)


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks