I have built plplot for the first time and successfully
run most of the Fortran examples by selecting the
wingcc option. Very nice stuff!

Now, I would like to run the GTK-Fortran examples that
use the cairo driver. I looked at lots of posts and docs,
but nothing I have tried works. In one place in the
documentation, it says something like : To add a
device driver, set the parameter ...   What parameter?
Where is it set?

Here is some information about what I tried. I would be
happy to provide more, but don't really know where the
problem is.

Windows 7 with cygwin.

cmake build command:
C:\"Program Files (x86)"\"CMake 2.8"\bin\cmake -G "MinGW Makefiles"
-DDEFAULT_NO_BINDINGS=ON -DENABLE_f95=ON
-DCMAKE_INSTALL_PREFIX=install ..

Here are some of the lines from the cmake output:

-- SWIG was not found. Please specify Swig executable location
   . . .
-- checking for module 'pango'
--   found pango, version 1.30.1
-- WARNING: pkg-config does not find pango.
-- checking for module 'pangoft2'
--   found pangoft2, version 1.30.1
-- WARNING: pkg-config does not find pangoft2.
   . . .
ENABLE_DYNDRIVERS:      ON
DRIVERS_LIST: mem;null;ps;svg;wingcc;xfig
DEVICES_LIST: mem;null;ps;svg;wingcc;xfig

Library options:
BUILD_SHARED_LIBS:      ON              PL_DOUBLE:      ON
=======================================
The six drivers in DRIVERS_LIST show up in driversd.

More info:

$ echo $PKG_CONFIG_PATH
C:\walt;C:\FortranTools\gtk\lib\pkgconfig

Walt@HP_Laptop /cygdrive/c/walt/FortranTools51/Src/Plplot/plplot-5.10.0/build
$ ls /cygdrive/c/FortranTools/gtk/lib/pkgconfig
atk.pc            cairo-svg.pc         gdk-3.0.pc          gmodule-export-2.0.pc     libffi.pc       pango.pc
cairo-fc.pc       cairo-win32-font.pc  gdk-pixbuf-2.0.pc   gmodule-no-export-2.0.pc  liblzma.pc      pangocairo.pc
cairo-ft.pc       cairo-win32.pc       gdk-win32-3.0.pc    gobject-2.0.pc            libpng.pc       pangoft2.pc
cairo-gobject.pc  cairo.pc             gio-2.0.pc          gthread-2.0.pc            libpng15.pc     pangowin32.pc
cairo-pdf.pc      fontconfig.pc        gio-windows-2.0.pc  gtk+-3.0.pc               librsvg-2.0.pc  pixman-1.pc
cairo-png.pc      freetype2.pc         glib-2.0.pc         gtk+-win32-3.0.pc         libtiff-4.pc    zlib.pc
cairo-ps.pc       gail-3.0.pc          gmodule-2.0.pc      libcroco-0.6.pc           libxml-2.0.pc

Walt@HP_Laptop /cygdrive/c/walt/FortranTools51/Src/Plplot/plplot-5.10.0/build
$ pkg-config --libs pango
-LC:/FortranTools/gtk/lib -lpango-1.0 -lm -lgobject-2.0 -lglib-2.0 -lintl

Walt@HP_Laptop /cygdrive/c/walt/FortranTools51/Src/Plplot/plplot-5.10.0/build
$ pkg-config --libs cairo
-LC:/FortranTools/gtk/lib -lcairo

=============================================
Do I need SWIG?
Why does it say it can't find pango when it just said it *did*
find pango?

I tried running cmake with -DPLD_wincairo. No difference.

Help would be appreciated. Thanks.

And if I can get this working, I would like to be able to generate
things like jpeg files.
--
Walt Brainerd