hello, thank you ,I suggest that we should  add notes for VS2010 or later ,you know,when people first time use cmake,and they install VS2010 or later,They will just change VS 9 2008 to VS 10 2010 like me,Then they find cmake
show error,people will feel confused,so we should add notes
"if you use VS2010 or later,you should use "-G VS 10 "rather than "-G VS 10 2010"