Hi!

I’m completely new to PLplot. I’ve been trying to get it working for a while now, but I keep having problems with it. My goal is to use it to create plots in jpeg format. I’m not looking for interactive plots, a user interface, command line args, or anything fancy. I’m using Microsoft Visual Studio 2012 and I’m writing the code in C++. I’ve copied the x00 C++ example from the PLplot Examples page (nearly) word for word, and this is the output I get:

 

*** PLPLOT WARNING ***

Unable to open cmap0 file cmap0_default.pal

 

*** PLPLOT WARNING ***

Unable to open cmap0 file cmap0_default.pal

 

*** PLPLOT WARNING ***

Unable to open cmap1 .pal file cmap1_default.pal

 

*** PLPLOT ERROR, ABORTING OPERATION ***

plInitDispatchTable: Could not open drivers directory, aborting operation

 

Plotting Options:

 

Enter device number or keyword (stream 1):

 

 

 

According to the documentation I’ve seen, it should be listing output options for me. Of course, the fact it can’t find the drivers directory may have something to do with that. I’ve tried putting in “JPEG” and many other keywords I’ve seen ,but nothing works. What do I need to do to get this to output jpegs? Do I need some sort of special jpeg driver?

 

Thanks!

 

Adam Lampman

ajlampman@babcock.com

 


This message is intended only for the individual or entity to which it is addressed and contains information that is proprietary to The Babcock & Wilcox Company and/or its affiliates, or may be otherwise confidential. If the reader of this message is not the intended recipient, or the employee agent responsible for delivering the message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by return e-mail and delete this message from your computer. Thank you.