L.S.,

I want to use the PLplot library in our modelling program and tried it with version 5.6.0. As results are promising, I wanted to use the latest package (which now uses "cmake") and for that I downloaded cmake and PLplot and also installed cmake without problems.

I untarred the PLplot tar ball and created a fresh build directory besides it. Then I tried the next :

#!/bin/sh
export PATH=/scratch/kshri0/cmake-2.4.7/bin:$PATH
export CC="gcc -O2"
export CXX="g++ -O2"
export FC="g77 -O2"
cmake -DCMAKE_INSTALL_PREFIX=/scratch/Plplot -DCMAKE_VERBOSE_MAKEFILE=ON \
      -DBUILD_SHARED_LIBS=NO -DPL_DOUBLE=NO  ../plplot-5.8.0 >& cmake.out
make >& make.out

The "cmake" seems to work, but the "make" failed, does anyone have a suggestion?

If any more information is needed, I am happy to provide it.

Thanks in advance for any help.
Summary of CMake build system results for PLplot

Install location variables which can be set by the user:
CMAKE_INSTALL_PREFIX:      /scratch/Plplot
CMAKE_INSTALL_EXEC_PREFIX  /scratch/Plplot
CMAKE_INSTALL_BINDIR       /scratch/Plplot/bin
CMAKE_INSTALL_DATADIR      /scratch/Plplot/share
CMAKE_INSTALL_LIBDIR       /scratch/Plplot/lib
CMAKE_INSTALL_INCLUDEDIR   /scratch/Plplot/include
CMAKE_INSTALL_INFODIR      /scratch/Plplot/share/info
CMAKE_INSTALL_MANDIR       /scratch/Plplot/share/man

Derived install location variables:
DATA_DIR        /scratch/Plplot/share/plplot5.8.0
LIB_DIR         /scratch/Plplot/lib
INCLUDE_DIR     /scratch/Plplot/include/plplot
BIN_DIR         /scratch/Plplot/bin
TCL_DIR         /scratch/Plplot/share/plplot5.8.0/tcl
PYTHON_INSTDIR 
DRV_DIR         /scratch/Plplot/lib/plplot5.8.0/drivers
DOC_DIR         /scratch/Plplot/share/doc/plplot
MAN_DIR         /scratch/Plplot/share/man
INFO_DIR        /scratch/Plplot/share/info

Other important CMake variables:

CMAKE_SYSTEM_NAME:      Linux
UNIX:                   1
WIN32:                 
APPLE:                 
MSVC:                           (MSVC_VERSION:  )
MINGW:                 
MSYS:                  
CYGWIN:                
BORLAND:               
WATCOM:          

SWIG_FOUND:             1
PERL_FOUND:             YES
X11_FOUND:              1

CMAKE_BUILD_TYPE:      
CMAKE_C_COMPILER CMAKE_C_FLAGS:                 /usr/bin/gcc 
CMAKE_CXX_COMPILER CMAKE_CXX_FLAGS:             /usr/bin/g++ 
CMAKE_Fortran_COMPILER CMAKE_Fortran_FLAGS:     /usr/bin/g77 
Target Fortran:
LIB_TAG:               

ENABLE_DYNDRIVERS:      OFF
DRIVERS_LIST: gd;hpgl;gcw;mem;null;pbm;ps;svg;xfig;xwin
DEVICES_LIST: png;jpeg;hp7470;hp7580;lj_hpgl;gcw;mem;null;pbm;ps;svg;xfig;xwin

Library options:
BUILD_SHARED_LIBS:      OFF             PL_DOUBLE:      OFF

Optional libraries:
HAVE_QHULL:             OFF             WITH_CSA:       ON
HAVE_FREETYPE:                          HAVE_PTHREAD:   OFF
HAVE_AGG:              

Language Bindings:
ENABLE_f77:             ON              ENABLE_f95:             OFF
ENABLE_cxx:             ON              ENABLE_java:            OFF
ENABLE_python:          OFF             ENABLE_octave:          OFF
ENABLE_tcl:             OFF             ENABLE_itcl:            OFF
ENABLE_tk:              OFF             ENABLE_itk:             OFF
ENABLE_pdl:             OFF             ENABLE_wxwidgets:       OFF
ENABLE_gnome2:          ON              ENABLE_pygcw:           OFF
ENABLE_ada:             OFF

-- Configuring done
-- Generating done
-- Build files have been written to: /scratch/kshri0/build


Results of "make" :

/scratch/kshri0/cmake-2.4.7/bin/cmake -H/scratch/kshri0/plplot-5.8.0 -B/scratch/kshri0/build --check-build-system CMakeFiles/Makefile.cmake 0

/scratch/kshri0/cmake-2.4.7/bin/cmake -E cmake_progress_start /scratch/kshri0/build/CMakeFiles 77
make -f CMakeFiles/Makefile2 all
make -f bindings/f77/CMakeFiles/plplotf77.dir/build.make bindings/f77/CMakeFiles/plplotf77.dir/depend
make[2]: Entering directory `/scratch/kshri0/build'
.
.
.
.
/scratch/kshri0/cmake-2.4.7/bin/cmake -E cmake_progress_report /scratch/kshri0/build/CMakeFiles 49
[ 59%] Generating sfstubs.f
cd /scratch/kshri0/build/bindings/f77 && sed -f /scratch/kshri0/plplot-5.8.0/bindings/f77/double2single.sed /scratch/kshri0/plplot-5.8.0/bindings/f77/sfstubs.fm4a > /scratch/kshri0/build/bindings/f77/sfstubs.f

sed: can't read /scratch/kshri0/plplot-5.8.0/bindings/f77/sfstubs.fm4a: No such file or directory
make[2]: *** [bindings/f77/sfstubs.f] Error 2
make[2]: Leaving directory `/scratch/kshri0/build'
make[1]: *** [bindings/f77/CMakeFiles/plplotf77.dir/all] Error 2
make[1]: Leaving directory `/scratch/kshri0/build'
make: *** [all] Error 2


Regards,
Hans Rijneke.

Shell International Exploration and Production B.V.
The Hague, The Netherlands - Trade Register no. 27002688
Address: Kessler Park 1, 2280 GS  Rijswijk, The Netherlands

(: +31 070 447 2737
*: <mailto:hans.rijneke@shell.com>
6: <http://www.shell.com/eandp-en>

Disclaimer of Liability:
This message, any attachment and response string are confidential and may be legally  privileged. It is intended only for the use of the parties to  whom it is addressed. If you are not the addressee indicated  in this message please notify the sender immediately by reply  email and destroy this message.

All information and  attachments remain the property of Shell