Hiroyasu YASUDA wrote:
On 2007/10/17, at 0:04, Alan W. Irwin wrote:

On 2007-10-16 19:04+0900 Hiroyasu YASUDA wrote:

Dear All:

I'm trying to install Plplot 5.7.4 on Cygwin, which is the newest of
cygwin on WIndows Xp, according to the Configure PLplot for cygwin in
PLplot wiki, http://www.miscdebris.net/plplot_wiki/index.php?

When I run "make" after running cmake, the command fail and then the
command show that:
  gcc: /DIVF: No such file or directory
  make[2] ***[bindings/f77/CMakeFiles/Plplotf77cd.dir/sccont.o]  
Error 1
  make[1] ***[bindings/f77/CMakeFiles/Plplotf77cd.dir/all] Error 2
  make: ***[all] Error 2

Please let me know that how to solve this problem.
To help us decide whether this is a general problem or simply an  
f77 issue,
please use cmake options that give you no bindings and only the simple
PostScript device that has no external library dependencies, i.e.,


If that completely simplified configuration has no problems, then  
you know
that the internal core of PLplot is working fine, and the problem  
is likely
to be just in the f77 bindings.  You can test a configuration with  
the f77
bindings disabled but all other bindings left on (and most devices  
left on)
by using the cmake option


In any case, for your next report of the issue, please
tell us all the details such as the command-line options you used  
for the
cmake command (starting from an empty build directory), the  
complete cmake
output, and the complete make output.  Also, what is the result of

cmake --version


Cmake version on the Cygwin is ver 2.4-patch 7.

I tried to run two option of cmake as follows.


  When I run "make" after cmake, make shows that:

   Could not open driver module ps
   libltbl error: No such file or directory
   make[2] ***[drivers/ps.o] Error 1
   make[1] ***[drivers/CMakeFiles/ps.dir/all] Error 2
   make: ***[all] Error 2

However, if I run "make" again, I succeeded to run "make" and "make  

(2) cmake-DENABLE_f77=OFF  -DENABLE_tk=OFF -DENABLE_tcl=OFF:

When run "cmake" with that options, cmake shows that:

CMake Error: The Fortran compiler "/cygdrive/c/Intel/Compiler/Frotran/ 
9.0/IA32/Bin/ifort.exe" is not able to compile a simple test program.  
It fails with the following output:

After this error message, I run "cmake" with same options again,  
cmake complete without error messages. And then "make" and "make  
install" succeed.

Since I want to use plplot with fortran on Cygwin eventually, I would  
like to know the instruction including fortran-enable on Cygwin.

Have you tried with g77, gfortran or g95 as the FORTRAN 77 compiler?
(all three are freely available under Cygwin and they have been used
in the context of PLplot and Cygwin much more than ifort. I think it
is worth a try).

I have seen similar error messages with other compilers. The basic
cause is that the CMake modules for such a compiler may not be
complete yet.

Please let us know if you succeed with any of these other compilers.