Alan W. Irwin wrote:
On 2007-01-11 08:45+0100 Arjen Markus wrote:

I checked the entire directory structure: there is only one file matching 
and that is cygfreetype-9.dll.

Hi Arjen:

One way cygfreetype-6.dll could still be interfering is if one of the system
libraries required by PLplot is out of date so that it is linked to
cygfreetype-6.dll rather than cygfreetype-9.dll.  The freetype library is
linked by a lot of different system libraries so the potential for such
inconsistencies is high.

I am not familiar with Cygwin but the Debian analogy I am using here is if
some Debian user was attempting to use a mixture of Debian stable and
unstable they would run into trouble because of library version

Anyhow, an upgrade to a self-consistent version of Cygwin may be the
solution in your case.

Hi Alan,

this was my mistake: I said entire directory structure, but I should have said
entire directory structure under c:/cygwin/lib. It so happens that there is a
cygfreetype-6.dll in the c:/cygwin/bin directory. However, there does appear
to be a conflict:
- cygfreetype-9.dll resides in the lib/X11R6 directory that contains a few
  DLLs that are needed for PLplot under Cygwin
- when I tried the examples with the default path (that includes /usr/bin)
  it did not work
- when I added /usr/lib/X11R6 it still did not work
- when I removed the freetype support, the examples finally started properly
  and I got the pictures I expected

I have not tried with a clean slate yet - hopefully this will solve the issue