i was this message in the archive and i am currently having the same issue, expect that when i run the tk driver on a linux station, everything works fine but i get the same problem when i try to run on a windows machine (using ssh and exceed). i get the message
X server insecure (must use xauth-style authorization); command ignored
    while executing
"send $client "set server_name [list $server_name]""
    (procedure "plserver_link_init" line 25)
    invoked from within
"plserver_link_init"
    (procedure "plserver_init" line 85)
    invoked from within
"plserver_init"
.......... now i saw that enabling and disabling xhost fixs the problem temporarily, but i dont understand. it seems like it should only work when xhost is disabled (doesnt). can someone explain this.. also, this is only a temporay fix, in the sense that if i log off the remote machine and log back in, i still get the same error. does someone have another fix for this?
 
FROM: Joao Cardoso
DATE: 04/08/2002 12:13:18
SUBJECT: RE:  [Plplot-devel] dev tk problems with SuSe 7.2

 

On Monday 08 April 2002 18:41, Alan W. Irwin wrote:
| On Sun, 7 Apr 2002, Joao Cardoso wrote:
| > [...]I now have a suse 7.2 and plplot 5.1.0 with
| > the tk driver works OK.
|
| Is this with the SuSe rpm's for tcl/tk or your own tarball based
| build/install of tcl/tk?

Standard suse rpms:

bash-2.05# rpm -qf `which wish`
tk-8.3.3-23

|  It is important to clarify this point
| because Geoffrey used his own tcl/tk tarball's and Olof's problems
| may be related to some incompatibility between plplot-5.1.0 and the
| SuSe 7.2 Tcl/Tk rpm's.
|
| Also it appears from separate e-mail that Olof can start a wish with
| no problems which seems to indicate his SuSe 7.2 problem with plplot
| 5.1.0 has nothing to do with xauth.

Actually, xserver security is only important when using tcl/tk "send" 
facility. The tk driver uses it in the inicial link setup.

Using the command "xhost" disables a secure xserver:

[jcard@feup] xhost +
access control disabled, clients can connect from any host
[jcard@feup] wish
%

OK, now from another xterm:

bash-2.05# wish
% send wish "set tk_version"
X server insecure (must use xauth-style authorization); command ignored
%

[jcard@feup] ./x01c -dev tk
Plplot library version: 5.1.0
X server insecure (must use xauth-style authorization); command ignored
    while executing
"send $client "set server_name [list $server_name]""
    (procedure "plserver_link_init" line 25)
    invoked from within
"plserver_link_init"
    (procedure "plserver_init" line 85)
    invoked from within
"plserver_init"


using "xhost -" sets the xserver secure again (if it was secure before)

[jcard@feup] xhost -
access control enabled, only authorized clients can connect
[jcard@feup] ./x01c -dev tk
Plplot library version: 5.1.0

Don't know if this help.
Olof, are you still with problems?

Joao


Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!