installation on intel Mac OSX 10.4.11

andy
2008-11-12
2013-03-15
  • andy

    andy - 2008-11-12

    We have tried the cmake installation of plplot5.9.0 on a MacBookPro (OSX10.4.11) and found that the generated make files cmake.out and make.out (attached below) have many warnings of multiple definitions and errors for wxwidgets even though PL_wxwidgets were set to off by editing, in the file config.h.cmake,  the line #cmakedefine PLD_wxwidgets = OFF  /* Nick added = OFF */ 

    The instructions are not that clear.  It appears that we are generating a make file for all bindings.  How can one limit to one, say Fortran?

    I can supply the cmake.out and make.out files but can't see where otr how to attach them to this post

     
    • Werner Smekal

      Werner Smekal - 2008-11-12

      Hi Andy,

      since Mac OS X 10.4 provides wxWidgets (I think version 2.5.4), cmake will find during the configuration process wxWidgets and does all necessary stuff. You shouldn't change config.h.cmake, since the line you changed will be "configured to"

      #define  PLD_wxwidgets = OFF

      and even if the value of PLD_wxwidgets is "OFF" it is still defined and this is all what the C code checks. Apart from that, this change only influences the C code and not the Cmake configuration step.

      The correct way to prevent cmake configure certain bindings is to use the binding options described in the wiki

      http://www.miscdebris.net/plplot_wiki/index.php?title=CMake_options_for_PLplot#Bindings_options

      So since you want to use only Fortran, you would need to add

      -DDEFAULT_NO_BINDINGS:BOOL=ON -DENABLE_f77:BOOL=ON

      to your cmake command line. If you use ccmake or cmakegui then you need to set this options in the GUI. No bindings will be compiled by default, only the ones (f77) you enable by hand.

      HTH,
      Werner

       
    • andy

      andy - 2008-11-14

      Werner,  Many thanks.  We got the f77 examples working but had the following error message for f95 when installing.
      .
      .
      Installing: /usr/local/lib/libplplotf95d.dylib
      CMake Error at bindings/f95/cmake_install.cmake:68 (FILE):
        file INSTALL cannot find file "/usr/local/plplot/plplot_build/plplot.mod"
        to install.

      Reading the CMakeLists.txt  under bindings/f95  by Andrew Ross 2006, he comments

      install(TARGETS plplotf95${LIB_TAG}
      ARCHIVE DESTINATION ${LIB_DIR}
      LIBRARY DESTINATION ${LIB_DIR}
      RUNTIME DESTINATION ${BIN_DIR}
      )

      # Yuk! All Makefiles are run from the top level build directory and
      # so the f90 .mod files end up there rather than in the bindings/f95
      # directory. Ifort and pgf90 both have a -module command line option to
      # override this location, but I'm not sure how portable that?
      install(
      FILES ${CMAKE_BINARY_DIR}/plplot.mod ${CMAKE_BINARY_DIR}/plplotp.mod ${CMAKE_BINARY_DIR}/plplot_flt.mod
      DESTINATION ${F95_MOD_DIR}
      )

      This appears relevant but what should we do?
      Also, how important is SWIG?  We don't have it installed.

      Cheers, Andy_w

       
      • Werner Smekal

        Werner Smekal - 2008-11-20

        Hi Andy,

        I believe that this error was already fixed some weeks ago, at least this sounds very familiar. You could try some recent plplot weeklies (since development is not that fast, that we have daily snapshots), which can be downloaded here:

        http://www.miscdebris.net/plplot_weeklies/

        since we are going to make another development release quite soon, the latest weekly snapshot should be quite ok to test. Alternatively you could check out the latest svn version of plplot as described in our wiki

        http://www.miscdebris.net/plplot_wiki/index.php?title=Subversion_access

        and get the latest bleeding edge version of plplot. Please try one of these and let me know if this solves your problems.

        Regards,
        Werner

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks