What is missing?

Quirks
2011-09-28
2013-03-15
  • Quirks

    Quirks - 2011-09-28

    I want to develope wxwidgets with the plplot library. On my system (Opensuse 11.1) i have installed the rpm's.
    1)  libplplot9 - Shared libraries for libplplot (5.8.0-7.1)
    2) libplplot-devel (5.8.0-7.1)
    3) plplot - PLplot, a scientific plotting package. (5.8.0-7.1)

    When i run wxPLplotDemo (the example file) in my console window i got the following error:

    …./wxPLplotDemo: error while loading shared libraries: libcsironn.so.0: cannot open shared object file: No such file or directory…

    How do i get this fixed?

    Greetz

     
  • Werner Smekal

    Werner Smekal - 2011-10-04

    You could try

    ldd wxPLplotDemo

    to find out, which library it can't find. You could then set LD_LIBRARY_PATH to the directory, where the missing libraries are and it should run. But this is a hack and the rpms seem to be buggy. It may be better to compile plPlot on your own.

    Regards,
    Werner

     
  • Quirks

    Quirks - 2011-10-11

    Ok i run ldd wxPLplotDemo and this is the result:

    ldd wxPLplotDemo
            linux-gate.so.1 =>  (0xffffe000)
            libplplotwxwidgetsd.so.0 => /usr/lib/libplplotwxwidgetsd.so.0 (0xb7ee6000)
            libplplotcxxd.so.9 => /usr/lib/libplplotcxxd.so.9 (0xb7ed5000)
            libplplotd.so.9 => /usr/lib/libplplotd.so.9 (0xb7e80000)
            libltdl.so.7 => /usr/lib/libltdl.so.7 (0xb7e74000)
            libdl.so.2 => /lib/libdl.so.2 (0xb7e6f000)
            libcsirocsa.so.0 => /usr/lib/libcsirocsa.so.0 (0xb7e67000)
            libcsironn.so.0 => not found
            libqhull.so.5 => not found
            libqsastime.so.0 => /usr/lib/libqsastime.so.0 (0xb7e5e000)
            libm.so.6 => /lib/libm.so.6 (0xb7e35000)
            libwx_baseud-2.8.so.0 => not found
            libwx_gtk2ud_core-2.8.so.0 => not found
            libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7db5000)
            libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7cc0000)
            libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7cb1000)
            libpthread.so.0 => /lib/libpthread.so.0 (0xb7c97000)
            libc.so.6 => /lib/libc.so.6 (0xb7b3b000)
            libwx_baseu-2.8.so.0 => /usr/lib/libwx_baseu-2.8.so.0 (0xb79e7000)
            libwx_gtk2u_core-2.8.so.0 => /usr/lib/libwx_gtk2u_core-2.8.so.0 (0xb7651000)
            /lib/ld-linux.so.2 (0xb7f18000)
            libz.so.1 => /lib/libz.so.1 (0xb763c000)
            libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb7246000)
            libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb71ae000)
            libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb7190000)
            libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb711a000)
            libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb70ef000)
            libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb70d3000)
            libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb708b000)
            libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb705a000)
            libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb7016000)
            libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb7011000)
            libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb700b000)
            librt.so.1 => /lib/librt.so.1 (0xb7001000)
            libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb6f3c000)
            libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb6f37000)
            libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb6f31000)
            libSM.so.6 => /usr/lib/libSM.so.6 (0xb6f28000)
            libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb6efe000)
            libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb6eda000)
            libtiff.so.3 => /usr/lib/libtiff.so.3 (0xb6e7f000)
            libXi.so.6 => /usr/lib/libXi.so.6 (0xb6e74000)
            libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb6e6c000)
            libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb6e61000)
            libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6e55000)
            libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb6e51000)
            libXext.so.6 => /usr/lib/libXext.so.6 (0xb6e3f000)
            libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb6e3b000)
            libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb6e35000)
            libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6db6000)
            libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb6d6e000)
            libxcb-render-util.so.0 => /usr/lib/libxcb-render-util.so.0 (0xb6d69000
            libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xb6d5f000)
            libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6d55000)
            libX11.so.6 => /usr/lib/libX11.so.6 (0xb6c22000)
            libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb6c1f000)
            libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6c01000)
            libXau.so.6 => /usr/lib/libXau.so.6 (0xb6bfd000)
            libpcre.so.0 => /usr/lib/libpcre.so.0 (0xb6bc9000)
            libselinux.so.1 => /lib/libselinux.so.1 (0xb6bac000)
            libexpat.so.1 => /lib/libexpat.so.1 (0xb6b84000)
            libICE.so.6 => /usr/lib/libICE.so.6 (0xb6b69000)
            libuuid.so.1 => /lib/libuuid.so.1 (0xb6b62000)

    Greetz

     

Log in to post a comment.