Help save net neutrality! Learn more.

Windows + MSVS 2008 installation

  • Min Yang Jung

    Min Yang Jung - 2009-05-20


    Now I've been aware that PLplot is awesome tool.
    However, I could barely see the installation guide, tutorial, and instruction written in a clean and simple way. What I've seen through wiki page, online/pdf documentation as well as sourceforge project page wasn't quite helpful.
    I succeeded to compile the project itself but couldn't generate or compile examples because PLplot cmake build seems to make Microsoft Visual Studio project files incorrectly.

    Personally, it would be way better if PLplot package is repacked so that users can easily compile and run nice-looking demos; Currently, I cannot even run just one demo.


    • Werner Smekal

      Werner Smekal - 2009-05-20


      reason is, that we don't suggest to use the project files for compiling PLplot. It may be possible but we never test it, so it's clear that problems will occur. The usual (and tested) way to compile PLplot with Visual C++ 2008 is to use the nmake utiltiy. Start the command line tools (there is a link in the Visual C++ menu, go to the plplot directory, make a build directory, cd into it and then

      cmake -G "NMake Makefiles" -DBUILD_TEST=ON other_cmake_options ..

      This will also build all examples in the built tree. If you used shared libraries you must also add the dll folder in the build tree to the path, so that the examples find the dlls.

      On the other hand you are right, that we should provide binaries of PLplot so that it's easy for Windows users to get going. I'm working on that, but I'm not there unfortunately.

      Documentation needs also to be updated, but there happened a lot in the last 3 years and the documentation is still behind. I hope this issue will be solved soon.


    • Min Yang Jung

      Min Yang Jung - 2009-05-20

      Thanks for your quick message.

      I've tried what you wrote as above but it doesn't work.
      This is what I got.

      D:\plplot-5.9.4\build>cmake -G "NMake Makefiles" -DBUILD_TEST=ON
      CMake Error: CMake executable cannot be found at /cmake.exe
      CMake Error: Error executing cmake::LoadCache(). Aborting.


      I'm not sure what I'm doing wrong. Just for your information, what I did for compilation was to generate build folder using cmake without any installation of other packages.

      Could you please guide me to be able to run nmake?
      (I have used nmake without any problems in case of other packages but this seems to be cmake related problem.)

      Thank you,

      • Werner Smekal

        Werner Smekal - 2009-05-22


        don't know if you didn't copy it or if it's a typo, but you must add the path to the source:

        cmake -G "NMake Makefiles" -DBUILD_TEST=ON ..

        if build is a subdirectory of the source. Remember to remove the build directory and remake it, if something goes wrong, since cmake caches some variables and this might lead to problems. To be on the save side remove the build folder and mkdir again.


    • Min Yang Jung

      Min Yang Jung - 2009-05-25

      Hi Werner,

      Yes, it worked out well and I could ran cmake as you guided. Thanks.

      At this time, however, I encountered nmake-related errors as follows.


      Microsoft (R) Program Maintenance Utility Version 9.00.21022.08
      Copyright (C) Microsoft Corporation.  All rights reserved.

      Scanning dependencies of target tai-utc-gen
      [  1%] Building C object lib/qsastime/CMakeFiles/tai-utc-gen.dir/tai-utc-gen.c.o
      Linking C executable tai-utc-gen.exe
      [  1%] Built target tai-utc-gen
      Scanning dependencies of target tai-utc.h_built
      [  1%] Generating tai-utc.h
      [  1%] Built target tai-utc.h_built
      Scanning dependencies of target qsastime
      [  1%] Building C object lib/qsastime/CMakeFiles/qsastime.dir/qsastime.c.obj
      Linking C shared library ..\..\dll\qsastime.dll
      The system cannot find the file specified
      ..\..\dll\qsastime.dll.intermediate.manifest : general error c1010070: Failed to
      load and parse the manifest. The system cannot find the file specified.
      NMAKE : fatal error U1077: '"C:\Program Files\CMake 2.6\bin\cmake.exe"' : return
      code '0x1f'
      NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\BIN
      \nmake.exe"' : return code '0x2'
      NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\BIN
      \nmake.exe"' : return code '0x2'


      From the error message "Linking C shared library ..\..\dll\qsastime.dll," it seems that qsatime.dll is not recognized by nmake, which means the process of generating qsatime.dll didn't work out.

      Could you please check this out?

      Thank you,


Log in to post a comment.