#62 version check for PDL perl module needs to be smarter

closed-fixed
None
5
2009-08-26
2009-08-26
No

The current version of the perl package PDL that plplot depends on is ""2.4.4_05", unfortunately the version checker in plplot isn't smart enough to recognize that this is greater than the minimum version of 2.4.1:

-- PDL_VERSION = 2.4.4_05
-- WARNING: PDL version < 2.4.1. Disabling Perl/PDL examples in tests

See the downstream Fedora bug: https://bugzilla.redhat.com/show_bug.cgi?id=519357

with a link to the full build log.

Discussion

  • Alan W. Irwin

    Alan W. Irwin - 2009-08-26

    This general problem has been fixed for some time in our svn trunk version by ignoring all characters after the first non-numeric one in the last number in the triplet. Please feel free to reopen this bug if the svn trunk version does not solve your issue. svn trunk version should be released as 5.9.5 next week.

     
  • Alan W. Irwin

    Alan W. Irwin - 2009-08-26
    • assigned_to: nobody --> airwin
    • status: open --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks